PDA

View Full Version : Avoid Wayland in F22



mrbrown79
14th June 2015, 12:48 AM
Forgive me for not being into the details on Wayland/X11, so I might not use the correct terms in my question below...

I have tried to select Gnome Wayland in F21 login form in order to test this. Unfortunately I wasnt satisfied with the performance of my tested X11 session (basically a session with graphics opened on a company server) when running in "Wayland mode".

I want to update to F22, but I read that this comes with Wayland as default display server. Can I disable this and stay with the good old X11 in F22?

Best regards,
Kenneth

vallimar
16th June 2015, 05:09 AM
Wayland is still an optional session in F22. Only GDM tries to use Wayland by default, and there is a
config setting (search the forum) to disable that also. Even after they switch to Wayland by default,
there will be an option for years to come to continue using regular Xorg. It won't suddenly disappear.

zatarregaza
20th June 2015, 11:09 PM
I've used nothing but Wayland since upgrading to F22. Immediately after the upgrade I noticed issues with video in particular. I tried messing with drivers for a few days before noticing I could use Wayland. Since using Wayland the video problems disappeared.

There are still freeze ups that I'm seeing here and there that weren't there before. I'm just not sure yet if they're due to bugs in F22 or Wayland itself that is causing them. Luckily they happen infrequently and not enough for me to take the time to research them.

Sent from my A0001 using Tapatalk

zatarregaza
20th June 2015, 11:11 PM
And on login you can choose to use Wayland or not to answer your question from the original post.

Sent from my A0001 using Tapatalk

lsatenstein
21st June 2015, 02:44 AM
Wayland works for me, but I think I feel it renders screens slower than X11 interfaces. So, for now I stick to the tried and true X11