PDA

View Full Version : Fedora 22 Workstation and NVidia Linux Driver install (GTX 980 card in my case)



Jeff72
27th May 2015, 07:35 AM
Fedora 22 Workstation and NVidia Linux Driver install (GTX 980 card in my case)(Allows full resolution and quiets down the NVidia fans in Linux)
================================================== ===========================================
Info:
Fedora 22 version installed: Fedora-Live-Workstation-x86_64-22-3.iso

NVidia Linux x86_64 driver installed: Current (2015-0619) driver used: NVIDIA-Linux-x86_64-352.21.run
Download the NVidia "Linux x86_64/AMD64/EM64T" driver listed above here: http://www.nvidia.com/object/unix.html

Install the pre-requisites:
---------------------------
dnf install dkms gcc kernel-devel kernel-headers

Blacklist and remove the default nouveau graphics driver:
---------------------------------------------------------
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
add "rd.driver.blacklist=nouveau" to middle of "GRUB_CMDLINE_LINUX=" line in /etc/sysconfig/grub
Example:
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rd.driver.blacklist=nouveau rhgb quiet"

Activate blacklist change:
--------------------------
grub2-mkconfig -o /boot/grub2/grub.cfg

Remove default nouveau driver:
------------------------------
dnf remove xorg-x11-drv-nouveau

Set computer to boot to run level 3 (non-graphical boot) and reboot:
--------------------------------------------------------------------
systemctl set-default multi-user.target
reboot

Install the NVidia driver:
----------------------------
chmod +x NVIDIA-Linux-x86_64-352.21.run
sh ./NVIDIA-Linux-x86_64-352.21.run
accept license
allow dkms module updates with new kernel updates
install 32bit compatibility
allow it to update your xorg.cfg file

If successful, then:
--------------------
Set computer to boot to run level 5 (graphical boot) and reboot:
----------------------------------------------------------------
systemctl set-default graphical.target
reboot





The information at the below web link by "Duke Nukem" was helpful in getting the above to work for Fedora 21 + 22:
================================================== =========================
"Step by step instructions: Fedora 20, NVIDIA GPU"
http://setiathome.berkeley.edu/forum_thread.php?id=74094


KERNEL UPDATES:
===============
NOTE: When updating kernels, the dkms package should technically re-enable the NVidia driver automatically.
If not, you can update the driver manually as listed below.

KERNEL UPDATES & manual NVidia driver update:
---------------------------------------------
If you update your kernel, then the new kernel will not by default have the NVIDIA driver enabled (Note: only if you do not have dkms installed).
You can reinstall the NVIDIA driver after updating your kernel and rebooting by doing the following:
Ctrl + Alt + F2 (this will get you a login)
Login as root
sh ./NVIDIA-Linux-x86_64-352.21.run
Accept license
Continue Installation
Yes to Install NVIDIA's 32-bit compatibility
Yes to update your x configuration file (may not be needed if upgrading)
reboot

Note: If a recent kernel update removes the blacklist file, you may have to do this again and then reboot and then do the above update section after a kernel update:
Blacklist and remove the default nouveau graphics driver:
---------------------------------------------------------
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
add "rd.driver.blacklist=nouveau" to middle of "GRUB_CMDLINE_LINUX=" line in /etc/sysconfig/grub
Example:
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rd.driver.blacklist=nouveau rhgb quiet"

Activate blacklist change:
--------------------------
grub2-mkconfig -o /boot/grub2/grub.cfg

Remove default nouveau driver:
------------------------------
dnf remove xorg-x11-drv-nouveau





2015-0619 Update:
-----------------
Current kernel and old NVidia driver would fail to get into X-window session. Upgrading the NVidia driver fixed this for me. This is how I fixed this:

At failed window, press Ctrl + Alt + F2 and login as root

Transfer the latest driver to your PC from another PC (I used NVIDIA-Linux-x86_64-352.21.run)

Note, if you need to enable SSH so you can transfer the new driver over (via scp or sftp) to your PC, run this to enable SSH and scp/sftp transfers:
systemctl enable sshd.service
systemctl start sshd.service

Then use some scp or sftp transfer program to copy the NVidia driver over to your non-working Fedora server. (I use FileZilla client with sftp transfer).

Set computer to boot to run level 3 (non-graphical boot) and reboot:
--------------------------------------------------------------------
systemctl set-default multi-user.target
reboot

Install the NVidia driver:
--------------------------
chmod +x NVIDIA-Linux-x86_64-352.21.run
sh ./NVIDIA-Linux-x86_64-352.21.run
accept license
allow dkms module updates with new kernel updates
install 32bit compatibility
allow it to update your xorg.cfg file

If successful, then:
--------------------
Set computer to boot to run level 5 (graphical boot) and reboot:
----------------------------------------------------------------
systemctl set-default graphical.target
reboot

Things should work again.

Louisda16th
30th May 2015, 07:41 AM
The answer is probably yes from the ISO you're using but just in case, are you using gnome as your desktop environment? I couldn't get the nvidia driver to work with gnome on F21 because the former didn't support wayland.

(If this matters, my laptop has both a GeForce card and Intel HD graphics)

Jeff72
30th May 2015, 08:12 AM
The answer is probably yes from the ISO you're using but just in case, are you using gnome as your desktop environment? I couldn't get the nvidia driver to work with gnome on F21 because the former didn't support wayland.

(If this matters, my laptop has both a GeForce card and Intel HD graphics)

Yes, i'm running the standard default Gnome.

I'm on a desktop, which actually may have Intel graphics too (I've never used it) but i'm using NVidia GTX 980 output.

$ echo $DESKTOP_SESSION
gnome

Jeff72
30th May 2015, 08:20 AM
The answer is probably yes from the ISO you're using but just in case, are you using gnome as your desktop environment? I couldn't get the nvidia driver to work with gnome on F21 because the former didn't support wayland.

(If this matters, my laptop has both a GeForce card and Intel HD graphics)

I also logged out and tried to login with "Gnome on Wayland" and my computer locked up, so it doesn't seem to work with Wayland currently.

Louisda16th
30th May 2015, 08:51 AM
The procedure didn't work for me (thank you for taking the time for writing the guide though!). I get the following screen instead of my log in screen:

http://i.imgur.com/5BIMGRR.jpg

I must also add that, during the installation, the installer never asked me about updating xorg.conf. Not sure why it didn't work. :(

Jeff72
30th May 2015, 06:55 PM
The procedure didn't work for me (thank you for taking the time for writing the guide though!). I get the following screen instead of my log in screen:

http://i.imgur.com/5BIMGRR.jpg

I must also add that, during the installation, the installer never asked me about updating xorg.conf. Not sure why it didn't work. :(

I'm pretty sure you need to have the xorg.conf updated. You can try running the installer again. It should allow you to reinstall.

Is your NVidia card chipset listed on the supported products here? http://www.nvidia.com/Download/driverResults.aspx/84721/en-us

TheDreamingMonk
31st May 2015, 12:47 AM
I get the same result here with a GTX760 on F22. Have tried disabling Wayland on GDM, manually creating a xorg.conf and still the same screen pops up.

So far I've just uninstalled them for now to do some research but it seems this post is the only one I've seen that resembles my problem.

Running nvidia-settings spits out some library errors;


# nvidia-settings

ERROR: libnvidia-gtk3.so.346.72: cannot open shared object file: No such file or directory
libnvidia-gtk3.so: cannot open shared object file: No such file or directory
libnvidia-gtk2.so.346.72: cannot open shared object file: No such file or directory
libnvidia-gtk2.so: cannot open shared object file: No such file or directory


ERROR: A problem occured when loading the GUI library. Please check your installation and library path. You may
need to specify this library when calling nvidia-settings. Please run `nvidia-settings --help` for usage
information.

Haven't looked at logs yet, will be digging through them a bit later when I get some more time though.

georgelappies
31st May 2015, 03:26 PM
I get the same result here with a GTX760 on F22. Have tried disabling Wayland on GDM, manually creating a xorg.conf and still the same screen pops up.

So far I've just uninstalled them for now to do some research but it seems this post is the only one I've seen that resembles my problem.

Running nvidia-settings spits out some library errors;


# nvidia-settings

ERROR: libnvidia-gtk3.so.346.72: cannot open shared object file: No such file or directory
libnvidia-gtk3.so: cannot open shared object file: No such file or directory
libnvidia-gtk2.so.346.72: cannot open shared object file: No such file or directory
libnvidia-gtk2.so: cannot open shared object file: No such file or directory


ERROR: A problem occured when loading the GUI library. Please check your installation and library path. You may
need to specify this library when calling nvidia-settings. Please run `nvidia-settings --help` for usage
information.

Haven't looked at logs yet, will be digging through them a bit later when I get some more time though.

I installed the drivers from RPMFusion and after a few reboots were able to login to the system. When trying to run nvidia-settings I get exactly the same error:



[georgelappies@devbox ~]$ nvidia-settings

ERROR: libnvidia-gtk3.so.346.72: cannot open shared object file: No such file
or directory
libnvidia-gtk3.so: cannot open shared object file: No such file or
directory
libnvidia-gtk2.so.346.72: cannot open shared object file: No such file
or directory
libnvidia-gtk2.so: cannot open shared object file: No such file or
directory


ERROR: A problem occured when loading the GUI library. Please check your
installation and library path. You may need to specify this library when
calling nvidia-settings. Please run `nvidia-settings --help` for usage
information.



P.S. How do I cleanly uninstall the nvidia drivers from RPMFusion?

oll
3rd June 2015, 03:40 PM
If your MB have secure boot you need to disable it before install RPMFusion nvidia akmod or kmod. You will need to keep it disabled. Don't know if this apply to nvidia original driver from nvidia web site.

urasoul
4th June 2015, 07:45 PM
i am seeing the same grey screen after the nvidia installer failed during a build process. i haven't been able to get to the log yet since i can now only get to a grub command line and am not familiar with the code/process for getting from the grub command line to something more useful that can navigate files and directories.
any tips are welcome here, since my machine is currently unusable!

oll
5th June 2015, 03:54 AM
i am seeing the same grey screen after the nvidia installer failed during a build process. i haven't been able to get to the log yet since i can now only get to a grub command line and am not familiar with the code/process for getting from the grub command line to something more useful that can navigate files and directories.
any tips are welcome here, since my machine is currently unusable!

When you get the grey screen then enter ctrl-alt-f2 this will get you to the tty screen. Then login, su and use yum or dnf to uninstall nvidia driver if you installed it from RPM. If you install from nvidia original driver I don't now how to uninstall it but there should be a how to some ware for this. You say the the installer failed so may be you have a bad or partial install, try the rescue option in the grub menu and see if this let you boot.

urasoul
5th June 2015, 09:47 AM
aha! great, thanks. i have successfully uninstalled the Nvidia driver by running the --uninstall flag on the installer script and then i moved to reverse all my previous changes and get the nouveau driver running again.
i edited the modprobe and grub files to go back to their original state and re-installed the nouveau driver. unfortunately though, when i rebooted fedora locked up on the coloured 'f' logo screen. in other words nouveau appeared to load and so did fedora, but just before the login screen appeared, the process halted (apparently permanently).. so i am now looking for how to resolve this.
all tips are welcome!

oll
5th June 2015, 02:06 PM
Try ESC and see were the boot process stop. Some times if you just reset and reboot it will boot ok. If not try the rescue option in grub menu.

urasoul
5th June 2015, 03:00 PM
hmmm.. ok, i didn't know ESC did that.. thanks.
i am seeing a BUG listed after the user manager was started:

'unable to handle kernel paging request at.....'

followed by a load of hex codes and other CPU level info.

rescue mode brought me back to the same grey screen with 'oops something went wrong'..

tuxdude
17th June 2015, 05:23 PM
Thanks for this Jeff72. It worked perfectly on my machine with GTX750Ti card.

Jeff72
19th June 2015, 11:48 PM
hmmm.. ok, i didn't know ESC did that.. thanks.
i am seeing a BUG listed after the user manager was started:

'unable to handle kernel paging request at.....'

followed by a load of hex codes and other CPU level info.

rescue mode brought me back to the same grey screen with 'oops something went wrong'..

I have updated the first post above for this issue and how to fix it. See update at bottom of first post. I ran into this issue also with current kernel and older NVidia driver.

You have to update the NVidia driver to work with the new kernel. See above 1st post.

Jeff72
19th June 2015, 11:58 PM
i am seeing the same grey screen after the nvidia installer failed during a build process. i haven't been able to get to the log yet since i can now only get to a grub command line and am not familiar with the code/process for getting from the grub command line to something more useful that can navigate files and directories.
any tips are welcome here, since my machine is currently unusable!

Try the Update I posted on post 1 at the bottom for 2015-0619 (today). It fixed my issue.

tuxdude
20th June 2015, 07:09 PM
Sorry, I should have said I downloaded the latest driver when I carried out the install.

barureddy
24th June 2015, 02:58 AM
I recently ran into a similar problem and thought people looking at this solution might in fact need mine. My problem was the I was installing on a UEFI system with secure boot enabled. When using kernel modules compiled without the right key, they will fail to load into the kernel. The solution is to disable secure boot in the UEFI bios. Another option is to compile the modules with the correct key. Sadly that will be a task for another day.

aleksijohansson
18th July 2015, 12:22 AM
The procedure didn't work for me (thank you for taking the time for writing the guide though!). I get the following screen instead of my log in screen:

http://i.imgur.com/5BIMGRR.jpg

I must also add that, during the installation, the installer never asked me about updating xorg.conf. Not sure why it didn't work. :(

I have this exact same issue on a Lenovo Y50-70 with Geforce GTX 860M. Running nvidia-xconfig after the installation creates the xorg.conf file, but it doesn't work with or without it. I've also tried to disable Wayland from the login and that didn't help either. Driver version 352.21.

hiGuys
18th July 2015, 01:33 AM
I think Linus summed up the relationship between Nvidia and Linux pretty succinctly:

http://www.zdnet.com/article/linus-torvalds-f-bombs-nvidia-over-lack-of-linux-support/ (http://www.zdnet.com/article/linus-torvalds-f-bombs-nvidia-over-lack-of-linux-support/)

I will never purposely build a machine meant for Linux with an Nvidia card as long as I live. It is unnecessary and causes more problems than one can shake a stick at.

jflory7
1st August 2015, 11:17 PM
Curious, does anyone know why the RPMFusion drivers for Nvidia are no longer updating? I will probably revert to using the Nvidia-provided drivers, but it's disappointing that RPMFusion isn't releasing any new updates for their packaging of the driver.

BlackenedBlood
16th August 2015, 05:44 PM
Hey all, a bit late but I'm getting stuck at

Blacklist and remove the default nouveau graphics driver:
---------------------------------------------------------
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
add "rd.driver.blacklist=nouveau" to middle of "GRUB_CMDLINE_LINUX=" line in /etc/sysconfig/grub
Example:
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rd.driver.blacklist=nouveau rhgb quiet"


Is this an actual command or am I just failing miserably? I should note this is in the ASUS G56JK with the GTX 850m.

Dutchy
16th August 2015, 06:58 PM
You need to edit that file (/etc/sysconfig/grub or /etc/default/grub), change that variable and then run the grub updater (grub2-mkconfig -o <location> where location is most likely /boot/grub2/grub.cfg or /boot/efi/EFI/fedora/grub.cfg).

Elsinbad
18th August 2015, 05:05 PM
I got this error

http://i59.tinypic.com/14vqj5d.jpg

Sent from my M7003Q using Tapatalk

philhall
24th September 2015, 06:47 PM
Just wanted to say thanks for this post, have just followed your instructions and they worked a treat. I can know use accelerated 3D graphics in VMware VMs.

Technical info for anyone that's interested:
Fedora 4.0.4-301.fc22.x86_64
LXDE.
nVIDIA 630 GT

boinc
5th March 2016, 05:32 PM
Fedora 22 Workstation and NVidia Linux Driver install (GTX 980 card in my case)(Allows full resolution and quiets down the NVidia fans in Linux)
================================================== ===========================================
Info:
Fedora 22 version installed: Fedora-Live-Workstation-x86_64-22-3.iso

NVidia Linux x86_64 driver installed: Current (2015-0619) driver used: NVIDIA-Linux-x86_64-352.21.run
Download the NVidia "Linux x86_64/AMD64/EM64T" driver listed above here: http://www.nvidia.com/object/unix.html

Install the pre-requisites:
---------------------------
dnf install dkms gcc kernel-devel kernel-headers

Blacklist and remove the default nouveau graphics driver:
---------------------------------------------------------
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
add "rd.driver.blacklist=nouveau" to middle of "GRUB_CMDLINE_LINUX=" line in /etc/sysconfig/grub
Example:
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rd.driver.blacklist=nouveau rhgb quiet"

Activate blacklist change:
--------------------------
grub2-mkconfig -o /boot/grub2/grub.cfg

Remove default nouveau driver:
------------------------------
dnf remove xorg-x11-drv-nouveau


I'm trying to install the nvidia driver for a GeForce 750Ti on a Fedora Server 23 installation (I'm suppose to process SETI at this server)

At this point it fails:

# dnf list | grep nou
fedmsg-announce.noarch 0.16.2-6.fc23 updates
perl-Text-Password-Pronounceable.noarch 0.30-10.fc23 fedora
sems-early_announce.x86_64 1.6.0-2.fc23 fedora
xorg-x11-drv-nouveau.x86_64 1:1.0.12-3.fc23 updates

# dnf remove xorg-x11-drv-nouveau.x86_64
No match for argument: xorg-x11-drv-nouveau.x86_64
Error: No packages marked for removal.

# dnf remove xorg-x11-drv-nouveau
No match for argument: xorg-x11-drv-nouveau
Error: No packages marked for removal.


Suggestions how to remove it?

Acropolis
13th March 2016, 07:51 PM
I'm trying to install the nvidia driver for a GeForce 750Ti on a Fedora Server 23 installation (I'm suppose to process SETI at this server)

At this point it fails:

# dnf list | grep nou
fedmsg-announce.noarch 0.16.2-6.fc23 updates
perl-Text-Password-Pronounceable.noarch 0.30-10.fc23 fedora
sems-early_announce.x86_64 1.6.0-2.fc23 fedora
xorg-x11-drv-nouveau.x86_64 1:1.0.12-3.fc23 updates

# dnf remove xorg-x11-drv-nouveau.x86_64
No match for argument: xorg-x11-drv-nouveau.x86_64
Error: No packages marked for removal.

# dnf remove xorg-x11-drv-nouveau
No match for argument: xorg-x11-drv-nouveau
Error: No packages marked for removal.


Suggestions how to remove it?

always in init 3 the changes for vga drivers because they have not loaded and we can do changes on them ( remove , update , install etc ) .

when you are in init 3 use the [dnf clean all & dnf -y update ] and recheck if dnf system things you have the nouveau driver package. also with [rpm -qa | grep "nouveau" ] command you can see if the package remains in your system .

also it is always good when we change the vga driver from open source to close source like nvidia and glx for ati vga to do a [dracut -f --kver `uname -r`] to regenerate the initramfs with the new driver loaded on the kernel .

if all are good and the loaded driver is the desired driver we can change to init 5 ( graphical init ) with [systemctl set-default graphical.target] command

p.s. i am installing gpm package to have mouse in init 3 to help me with copy pastes and if i want to be sure that a driver will never loaded even after updates or upgrades i am using a script to control it via systemd mechanism like i wrote in this guide : http://forums.fedoraforum.org/showthread.php?t=309000