PDA

View Full Version : no touchpad on Dell Inspiron 14 3000



Johnny von Trap
22nd April 2015, 03:41 AM
Hi,

I installed Fedora 21 a few days ago on a new Dell Inspiron 14 3000 and ran yum update on it to make sure the packages were up to date.

Unfortunately, the touchpad is not working. (Not at all that is, no scrolling, no clicking, nothing.)

I hope someone can help me out figure out how to fix this. Some info on the system (let me know what other info is needed!)

uname -r gives 3.19.3-200.fc21.x86_64
Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ DLL06AB:00 06CB:78F1 id=11 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=13 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft Wireless Optical Mouse® 1.00 id=15 [slave pointer (2)]

(The MS mouse is plugged in via usb so that I can use the laptop at least.)

dmesg gives the following:

dmesg | grep -i syn
[ 0.248746] pnp 00:03: Plug and Play ACPI device, IDs SYN0609 SYN0600 SYN0002 PNP0f13 (active)
[ 1.681100] psmouse serio1: synaptics: queried max coordinates: x [..5662], y [..4700]
[ 1.709155] psmouse serio1: synaptics: queried min coordinates: x [1322..], y [1240..]
[ 1.768017] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2a1, caps: 0xf40123/0x840300/0x12e800, board id: 3096, fw id: 1781191
[ 1.803595] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input7

.

The touchpad itself is fine I think, it works OK in the BIOS for instance.

Any help is appreciated!




xinput gives

amitsark
23rd April 2015, 02:53 AM
after login, go to Settings >> Mouse and touchpad, then check the 'Tap to click' checkbox.

Does it help?

Johnny von Trap
23rd April 2015, 02:42 PM
Tried this, but unfortunately it does not help.

What confuses me is the following output:

ls /etc/X11/xorg.conf.d/
00-keyboard.conf

It appears that X does not recognize that there is a Touchpad? Should I place some sort of config-file here? (I'm used to Xorg.conf-files from older Fedora's, I don't know how FC21 deals with this stuff.)

Johnny von Trap
23rd April 2015, 05:04 PM
Some more info:

I put FC22 on a Live USB to see if the touchpad would be recognized when booting the Live USB. Still not.

Also, the following is included in /proc/bus/input/devices

I: Bus=0011 Vendor=0002 Product=0007 Version=01a1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input7
U: Uniq=
H: Handlers=mouse0 event5
B: PROP=5
B: EV=b
B: KEY=e520 610000 0 0 0 0
B: ABS=660800011000003

Johnny von Trap
28th April 2015, 08:58 PM
At the risk of adding too many replies to my own post, some more info.

I ran evtest today (in non-X, as root) to test the touchpad. At first, it appeared to be hung on `Testing . . .', no output followed. I could move and click all I wanted on the touchpad, but nothing.

Don't ask me why, but I clicked on the `left button' of the touchpad and moved my finger to the `right button'. This triggered a response in evtest. After that, it also responded when I simply mover my finger over the touchpad.

I restarted X, hoping that `swiping from left button to right button' might awaken the touchpad. Nope.

Still think it's progress in debugging though. Any synaptics-experts have an idea how to proceed from here?

hiGuys
26th July 2015, 06:39 PM
Sorry no help here, just confirmation I am experiencing the same thing. It worked with Dell's pre-installed ubuntu, but a Dell repo update bricked that system. Running Fedora on it now with the same annoying issue of no trackpad. USB mouse works fine in the meantime.

trevorc
13th September 2015, 03:40 PM
I upgraded to fedora 23 (I know it is still pre-release) now my touch-pad works just fine. It would appear that the 4.2 kernel fixes the driver problems. So next month when f23 is officially released touch-pad drivers will be fixed, or you can upgrade to pre-release if you are adventurous.

MekkaGodzilla
12th October 2015, 01:12 AM
I'm glad this is fixed in F23.
I found a fix for F22 though, on askubuntu.

I had to tweak it a bit for fedora.
Here we go :

edit /etc/default/grub

add i8042.nopnp at the end of the options of GRUB_CMDLINE_LINUX

then run


sudo grub2-mkconfig -o /boot/grub2/grub.cfg
echo "blacklist i2c_hid" | sudo tee /etc/modprobe.d/i2c-hid.conf
sudo depmod -a
sudo dracut -v -f
echo "synaptics_i2c" | sudo tee -a /etc/modules

Reboot and the trackpad should work.