PDA

View Full Version : [SOLVED] How to boot with the F1 option?



phyjuno
17th April 2015, 10:37 PM
Hey Guys,

You would ask that why I want to do this, and let's say I like it that way. During bootup (I recently installed Fedora 21) if I press F1 I see a whole list of [OK] and [Failed] lines while the system is starting. And normamly I would see the Fedora balloon in the center of the screen if I do not press F1. Is there a way to boot always with the first option so that I do not have to press F1. I also remember that in the good old days the same screen would ask for the the userid and passwd. Is there a way to do that without having to go into the GUI mode for entering the passwd.

Actually I just got back to using linux after 10 odd years after working with windows platform. And as much as I hated windows, I was stuck with those because my lab and collaborators always used windows. Now that I I am done with my phd and have some time to myself I just wanted to enjoy the good old times. That said can you please help me enjoy linux in the traditional old way?

You won't believe how much I would appreciate your help.

Cheers
Juno

jims
17th April 2015, 11:01 PM
You might want to preview the effects of making this change by editing the command line during grub kernel selection by pressing e and removing the quiet parameter from the command line.

If this is the style of systemd messaging you want to see during boot, then make the change permanent:

I am basing this change on a non-uefi, i.e., standard mbr style configuration.

Go into /etc/default/grub and edit the GRUB_CMDLINE_LINUX line. Remove the option quiet.
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.keymap=us rd.lvm.lv=fedora/root rhgb quiet"
then run
# grub2-mkconfig -o /boot/grub2/grub.cfg

phyjuno
17th April 2015, 11:29 PM
That does not help. I do see a few lines of processes starting at the bootup just before the balloon shows up. Previously the _ cursor blinked for a while before the balloon showed up. Changing the grub.cfg did not get rid of the balloon.

smr54
17th April 2015, 11:49 PM
Do you boot into a graphic login? If so, you probably have to run


systemctl set-default multi-user.target

jims
17th April 2015, 11:55 PM
My apologies.

Try the edit on the command line and remove both the rhgb and quiet parameters, then see if this satisfies your needs. If so, make the change permanent.

PabloTwo
18th April 2015, 12:24 AM
You don't need to edit anything to do this. Just a simple:

# plymouth-set-default-theme details -R
You can leave your kernel command line intact as it was.

phyjuno
18th April 2015, 01:11 AM
Thanx smr54 and jims. smr54, your option allows me to login to complete non-gui mode, while jims your option gives me the startup status during the boot and then gives me the gui for login.

smr54 how do I revert the changes after your command?

thanks again

juno

smr54
18th April 2015, 02:53 AM
Just changed multi-user.target to graphical.target


systemctl set-default graphical.target

https://fedoraproject.org/wiki/Systemd#How_do_I_change_the_target_.28runlevel.29_ .3F

phyjuno
18th April 2015, 02:56 PM
Thanks Guys ...Tht works ...