PDA

View Full Version : Unable to boot back to windows 8.1 after installing Fedora 21



narotekang
9th April 2015, 06:36 PM
A week ago I had this problem that took me almost a week to fix it with a very simple solution that I didn't think it was gonna work, but it did. So now I decide to share this problem and solution so that people that meet the same problem will not suffer like I did. :dis:

I know this thread is long that's why I divide them to parts If u are just here for the solution then go to the solution part and read it. I'm not a native English speaker, so forgive my bad grammars.

*Introduction*
I have a Lenovo Y50 that runs a pre installed windows 8.1 ,64bit. After awhile I decided to try out Linux, *I could not try other operating system due to some security issue you will see later in this thread* so I did try to run a few versions, However, I love Fedora the most so i decided to install Fedora 21 as a dual boot.

*How I boot from Fedora and problems
I burn a fedora 21 LIVE image iso file to a DVD then I run it. However, I could not boot from CD due to Windows 8's new security feature which is called UEFI mode as I remember. In order for me to boot from CD I had to switch the boot mode in bios settings to LEGACY mode. So I did, boot from CD and installed fedora as a dual boot, I let fedora auto configure my drive partition and i guess that was a mistake :fp:

After everything is done, I tried to boot back to Windows 8.1 but I couldn't find Windows 8.1. That's when I know I *eff*ed up a little. :beat: I read so many threads and solution about grub loader then later I somehow manage to have Windows 8.1 option listed in grub loader but still the problem is I can't load back to Windows 8.1. It shows many errors, I read almost every threads about the problem I had, but I still couldn't boot back to Windows. I made a Windows 8.1 LIVE USB and DVD both ways I thought if I can boot from it I could get it to auto fix my bootloader things but unfortunately I couldn't boot from any of them.

I'm not going to list all the things I did trying to fix that problem because it will take days for you to read, I even thought of reinstalling Windows 8.1 but it was so precious to me that's why I couldn't risk losing it.

*SOLUTION*
After many sleepless days, missing my Windows 8.1 I went to meet a professor at my university. What he told me to do was to create a recovery drive and let it auto fix my computer. Seriously though, I giggled a little and didn't thought it would work, however I had no other choice but to try whatever I can. So i did this follow this : " http://windows.microsoft.com/en-us/windows-8/create-usb-recovery-drive " , After I did all that, I boot and let it recovery/fix my bootloader and it worked like a magic. I couldn't believe my eyes. I guess I didn't try that solution because I thought it's too simple I focus too much on complex things, I'll have to try to look at the problem from another angle I guess.

So if you have the same problem as I did, I would recommend you to try that solution, otherwise, follow other threads.

By trying to fix my computer, I learn a lot of linux command from it. So It's not that bad :dance::dance: Goodluck.

Dutchy
10th April 2015, 12:00 AM
Sounds like a feature to me ;p

Dual booting (with Windows) always has been kind of messy and now with all these buggy UEFI implementations which may or may not use secure boot and could be running a Windows version that uses some fancy kernel hibernation feature that might cause inconsistencies with an NTFS filesystem, things have gotten a lot messier.