PDA

View Full Version : [SOLVED] LC_ALL=C in the .desktop file



Przemas
8th April 2015, 04:07 PM
Ok , so I have oen app that behaves badly when launched normally. I found a solution - you need to type LC_ALL=C before launching the app. So basically you launch it by :

LC_ALL=C /path/to/app

But I wonder how should I modify the .desktop file to make it work ?

PabloTwo
8th April 2015, 04:41 PM
But I wonder how should I modify the .desktop file to make it work ?
Though I've never had to do this, this document (http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-1.0.html) explains how this is done in a *.desktop file in the "Localized values for keys" section near the beginning. I find the instructions somewhat confusing, but maybe you can work it out by experimentation.

Przemas
9th April 2015, 09:58 AM
@Pablo: can you tell me exactly where in that text this is being explained? Flipped through it and I can't see an indication howto do it.
I know I simply can't type something like this in the desktop file:
Exec="LC_ALL=C programname"
-it won't work.

vallimar
9th April 2015, 12:18 PM
The localized values in the .desktop files is strictly for display.
To do what you want, you probably need to point the .desktop to an
intermediary script file that will call the actual executable with the
environment changes you want.

Przemas
9th April 2015, 03:31 PM
found the solution :

Exec=env LC_ALL=C path/to/app

- did the trick . The good thing is that it is now all contained within .desktop file, without external script (considered this option - thx vallimar) .