PDA

View Full Version : [SOLVED] Time stamps during booting



upnort
16th March 2015, 08:41 PM
On my F21 system, when rc.local runs I see traditional kernel time stamps like this:

[ 32.12345] rc.local[871]: Some stdout text.

On CentOS 7 I do not see the time stamp:

rc.local[871]: Some stdout text.

I use the "quiet" boot parameter parameter in both systems.

How do I configure F21 to not show the time stamps?

stevea
16th March 2015, 10:56 PM
To get rid of all of them you need to rebuild the kernel with no CONFIG_PRINTK_TIMES.
You can diddle the /proc/sys/printk params once the sysfs pseudo filessystem is mounted - but you'll have a hundred messages by then.

upnort
16th March 2015, 11:57 PM
To get rid of all of them you need to rebuild the kernel with no CONFIG_PRINTK_TIMES.
Ok. Apparently (I did not look) the CentOS kernel is built that way and the F21 kernel is not. :)

vallimar
17th March 2015, 04:20 AM
Try adding "printk.time=0" to the grub boot line.

upnort
17th March 2015, 04:36 AM
Try adding "printk.time=0" to the grub boot line.
Hey! That works nice! :D

upnort
2nd April 2015, 07:11 PM
Try adding "printk.time=0" to the grub boot line.
This trick no longer works with the 3.19 kernels. Any ideas?

Edit: Hmm. Looks like I got confused. The kernel time stamp is still gone, but there is a [number] in brackets that appears after "rc.local." Probably the process number. This likely was there all along. I don't know why that struck me as odd. Not enough sleep I guess. :)

stevea
3rd April 2015, 05:49 AM
The 4.0 kernel still shows


printk.time= Show timing data prefixed to each printk message line
Format: <bool> (1/Y/y=enable, 0/N/n=disable)

So it should still work.
Bugzilla if you care enough.
[tip o' the hat vallimar - good catch on the kernel params].