PDA

View Full Version : Opera 27 rpm file



Jagcoxa
31st January 2015, 01:28 PM
Hello

i have build an RPM of opera 64Bits.

Opera does not provide an rpm by default, but only debian files, and windows files.

I have tested the package, and it works perfectly.
The dependency libudev0 has been replaced by libgudev, which already excists in a standard installation.

All users should download the package into a dir, and run:
rpm -Uvh *.rpm

Screenshot:
http://s11.postimg.org/oppqg0zg3/snapshot1.png

Website: www.opera.com

opera-33.0.1990.115-1.fc23.x86_64.rpm
LINK (https://mega.nz/#!fEFRVLLL!zwoepc_zvuwppuGFtrqlKRi4C8D7WIeY-kIbnV7zlqs)

opera-33.0.1990.58-1.fc23.x86_64.rpm
LINK (https://mega.nz/#!XB8V1LAB!kUirCoHsTHzdEJ90xJV-vasMhT9DLYpfLC4rLv1NMtw)

** Source rpm **
LINK (https://mega.nz/#!SAkmCQyb!n1epdBWjgbMFLgr1UPAj-GtBYmRs8-Bi9nrZId47530)

** Homepage button **
LINK (https://addons.opera.com/nl/extensions/details/homepage-in-new-tab/?display=en)

Enjoy

bob
31st January 2015, 03:04 PM
Moved to Guides

If you installed with yum vs. rpm, wouldn't it pick up the libudev0 dependency? Gave it a try with yum and "no" it is still missing. Nice work!

Jagcoxa
31st January 2015, 03:17 PM
Moved to Guides

If you installed with yum vs. rpm, wouldn't it pick up the libudev0 dependency?

no, because libudev0 is not available in the repo's of FC21

opera (latest ) and it's dependencies are not avialable in any repo for Fc21

bob
31st January 2015, 03:22 PM
Yes, tested, edited my post. Thanks for your hard work.

Jagcoxa
31st January 2015, 03:26 PM
no problems friend

fedora is cool, and i want to contribute to the community as best as i can:dance:

Chow

lambcutlet
28th February 2015, 09:25 PM
for information there is another 'ruario' doing opera for fedora
i know nothing about the person but i have been using it for a while now
today it is at version 27.0.1689.76

http://software.opensuse.org/download.html?project=home%3Aruario%3Aopera&package=opera-stable

dsngjoe
18th March 2015, 03:38 AM
Thanks guys this is great work!

rbrick49
18th March 2015, 08:08 AM
well thats strange I just installed opera 27 via dnf and it pulled in the dependency
regards Ron

Jagcoxa
15th November 2015, 12:27 PM
Opera has been updated to version 33.0.1990.115.

nonamedotc
7th July 2016, 03:04 AM
Thread unstuck since opera now provides rpm (as far as I can tell)