PDA

View Full Version : Offline updates failing, other issues with GNOME Software, Apper or pkcon



AdamW
20th January 2015, 01:16 AM
Hi, folks! I've posted in a couple of threads that look to be caused by this, but as many people may be affected, it probably merits an announcement too. We're in the middle of dealing with this issue - expect this post and thread to be updated as the update goes through various stages.

We're aware of some bugs in the PackageKit stack (PackageKit itself, and libhif) in Fedora 21 (since libhif 0.1.7 was released as an update back in December) which can cause the following:

* Offline updates (the standard Workstation update mechanism, where it notifies you of updates and you reboot to install them) failing
* Any other kind of package operation - install, update, remove - failing with PackageKit-based apps: GNOME Software, Apper (KDE), pkcon (console)

An update is available which should resolve all the known issues in this area:

https://admin.fedoraproject.org/updates/FEDORA-2015-0921

If you're affected by these problems, we recommend you install the update, and avoid using PackageKit-based applications until you've done so. In most cases, just installing the update should be sufficient. If you've been unfortunate enough that a failed operation messed with the PackageKit database, you may need to do the following after installing the update:

1. Reboot
2. Run 'pkcon repair' as root
3. Reboot again

Please let us know if you continue to have problems of this kind after doing that.

To install the update, you can do this:

# yum update --advisory=FEDORA-2015-0921

We do apologize for this problem!

MadmanRB
23rd January 2015, 05:19 AM
Good fix, I was having upgrade issues.
Upgrades would appear in Yumex but not anywhere else.

antikythera
24th January 2015, 12:20 AM
Thanks guys for the fix.

My clean VM install tonight pulled down the necessary patched files from stable during the first forced 'yum update' I did in terminal. :D

only problem is Gnome Software is completely blank after this bug manifested https://bugzilla.redhat.com/show_bug.cgi?id=1136837 straight after restarting and logging on. (now on the CC list)
I didn't run gnome-software at all before patching. I ran pkcon repair just in case that was an issue anyhow and got this:


[root@VM-FedoraWkstn ~]# pkcon repair
Failed to contact PackageKit: Error calling StartServiceByName for org.freedesktop.PackageKit: GDBus.Error:org.freedesktop.DBus.Error.TimedOut: Activation of org.freedesktop.PackageKit timed out
[root@VM-FedoraWkstn ~]#

ErrHuman
28th January 2015, 01:42 PM
I had the same problem with pkcon repair.

Running yum update fixed that timeout issue for me.

antikythera
28th January 2015, 05:20 PM
I'll try that later. updating with yumex should have had the same effect though. So there may have been a patch released since I was dabbling with it which fixes the issue.

EDIT - nope still not working. Thanks anyhow. As much as I'd like to find out the actual cause I don't have the concentration level needed at present to wade through the yum output so I will simply go back to the original VM state from image and start again. Much less taxing.

Dutchy
4th February 2015, 03:34 PM
There is a new bug where it complains about mirrors (https://bugzilla.redhat.com/show_bug.cgi?id=1188600).
This is fixed by libhif-0.1.8-4.fc21 which has been pushed to stable.
So to get it update it with yum/dnf:

sudo dnf upgrade libhif

# When you hit a mirror that isn't updated get it from testing:
sudo dnf upgrade libhif --enablerepo=updates-testing

# After this you need to restart the packagekit service
sudo systemctl restart packagekit.service

# At this point gnome-software should work again

SamSmall
4th February 2015, 10:19 PM
Dear Dutchy!

It works, thanks a lot!!

flaflashr
25th February 2015, 10:36 PM
Did not work on FC21, KDE spin.

I had previously done yum update, and applied 317 updates in one session, and 71 in another.

When I try the above, I get the following

sudo yum update --advisory=FEDORA-2015-0921
[sudo] password for kd1yv3:
Loaded plugins: langpacks
No packages needed for security; 0 packages available
No packages marked for update

I also tried the pkon repair, and it worked, but I still don't think the advisory has applied anything.

Kindly advise.

JimR

newwaysys
27th February 2015, 01:13 PM
Hello guyzz , m also suffuring from this problem.
Since the middle of last week we’ve been aware of some bugs with the PackageKit stack. The initial bug report was for offline updates failing, but during testing of the fix for that, various other bugs were identified which could potentially cause problems with many PackageKit transactions – that’s mostly documented in this report. Mostly, though, folks only seem to have been noticing issues since libhif 0.1.7 came out as an update in late December.

Richard Hughes has been working hard to fix the problems, and we now have an update in updates-testing which we’re fairly confident should fix all the known bugs in this area. Note: if you’re seeing the error SearchGroups not supported by backend from Apper, that’s a different issue, not covered by this post.
:)