PDA

View Full Version : HOW to Install Broadcom WiFI Driver on Fedora 21



Andre Gompel
6th January 2015, 06:02 AM
Step

0: Make sure you have a Broadcom WiFi chip:

lspci | grep -i broadcom
03:00.0 Network controller: Broadcom Corporation BCM43228 802.11a/b/g/n

1 : If all you have is a wifi connection, the first step is to aquire (vailable on Amazon, etc... A USB Widfi dongle TP-Link "TL-wn821N"
The TP-Link model TL-WDn3200 also work (but not as well !)

2 : Insert the Wi-fi Dongle, and the network manager should show you access point. Nice.

3 : Not required, but useful feedback:

dmesg |grep -i atheros
[ 8123.808180] usb 8-1: Atheros AR9170 is registered as 'phy1'

4 : Not required, but a good idea:

sudo yum update

5 : Using the firefox brower, http://rpmfusion.org/

Click on "Enable RPM Fusion on your system and verifying RPM Fusion's signing keys"
Execute the procedure for both rpmfusion-free andrpmfusion-nonfree. (Install and Enable repositories).

6 : sudo yum install kmod-wl akmods akmod-wl kernel-devel

This will install the Broadcom STA driver, and also what is need for automatic update for newer kernel.

7 : Now you can remove the USB dongle, reboot, :)and the Broadcom driver will work.:rolleyes:
Actually to the best of my recollection, it works without rebooting.

8 : Please validate (and post your observations) that the procedure described above works at 100%, including survive a kernel update.

Notes :

1 : This also works with older versions of Fedora, since Fedora 17.

2 : In the future, as long as Broadcom insist to not provide open source driver, in the Linux Kernel, main tree,
it is preferable to not purchase a computer with Broadcom WiFi, Wifi with Atheros chip, and Intel Chip work just "out of the box".

On Windows typing (from command line) msinfo32 should provide the proper information.

biggb
16th March 2017, 04:05 AM
Thank you Andre ... this worked for me after much searching!

A key piece to your instructions was going to RPMFusions website and clicking their link. Other help threads had posted outdated links. Well done.

I'm running Fedora Workstation 25 on an HP Elitebook with Broadcom BCM43228 wlan adapter.

No WLAN until used your fix. Have not tried any kernel updates as of yet.

antikythera
16th March 2017, 09:40 AM
still slightly outdated instructions but glad they worked for you. the command for F25 onwards to install the packages as per steps 4 and 6 should use dnf and not yum as it has been deprecated.

4. replacement command also makes sure the metadata for dnf is current so you don't get any transaction failures due to broken dependencies

sudo dnf upgrade --refresh

6.
sudo dnf install kmod-wl akmods akmod-wl kernel-devel