PDA

View Full Version : [SOLVED] Fedora 20 text mode is not displayed



kemot90
17th December 2014, 09:26 PM
Hi,

I have some issue on Fedora 20 with text mode. When I switch mode with Ctrl+Alt+F2 black screen is displayed and nothing more. I've faced with this problem on Ubuntu 14.04 LTS. On this system I've installed nvidia-331 package (this package no need to stop graphical environment). After this my graphical mode has crashed (low resolution, no Unity bar, only wallpaper) but I was able to switch to text mode and install Nvidia 343 drivers which supports my GeForce GTX 970. It fix both, text mode and X graphical mode. I wonder how to fix it on Fedora 20. There is no nvidia-331 package available from yum and drivers downloaded from Nvidia website required to stop X environment. Please, help me deal with this.

nsnbm
18th December 2014, 01:09 AM
If you want to get a console to do some work you can reboot and when the grub menu comes up, press the e key to enter Edit mode. Then you cursor down to the kernel boot line and then write either the word single or the number 1 at the end of the line within the quotation marks. (The kernel line might not be visible at first but move the cursor down and it will come to it). Then press the F10 key or do CTRL-X to boot into single mode which should give you a shell to work in where X is absent.

kemot90
18th December 2014, 08:21 PM
@nsnbm I tried this also by changing rhgb quiet to text 3 in kernel boot line and I got information about conflicting fb hw usage nouveaufb vs efi vga. This confirmed my suspicion that my problem lies in that I don't have installed any Nvidia drivers and I have to replace nouveaufb with it. I followed by this article (http://www.if-not-true-then-false.com/2014/fedora-20-nvidia-guide/) which describes how to install some Nvidia driver package without stoping X. This caused that my system booting hangs at some point but I was able to enter to text mode by Ctrl+Alt+F2. I've installed earlier downloaded NVIDIA-Linux-x86_64-343.36 drivers with success. Now my Fedora starts perfectly.

nsnbm
19th December 2014, 12:34 AM
Glad you got it sorted out.