PDA

View Full Version : [SOLVED] F21 - Compose Keys messed up



Anfasa
16th December 2014, 12:43 AM
Hello,
I used to use the right Control key as my Compose key. However, since I updated to F21, it is not working anymore as a compose key (Ctrl T - M won't type '' but open a new tab under Firefox, for example). I've tried moving it to another key (right Alt) and back, but it didn't help. It actually messed up this other key : Whatever setting I use for the compose key (disabled at the moment), my Alt-Gr key will now work as one, preventing me from typing special characters, for example.
Does anyone know how to fix that?
Thanks,

pie3636

P.S. : I'm using a standard French AZERTY keyboard.

dobbi
16th December 2014, 02:19 AM
Here on F20 Gnome.

Go to Settings -> Keyboard -> Shortcuts(tab) -> Typing -> Compose and activate the compose key.

Manual:


$ dconf dump /org/gnome/desktop/input-sources/ > $HOME/Documents/gnomesettings.txt
$ gedit $HOME/Documents/gnomesettings.txt &

- locate xkb-options

[org/gnome/desktop/input-sources]
show-all-sources=true
current=uint32 1
sources=[('xkb', 'us')
xkb-options=['lv3:menu_switch', 'eurosign:e', 'compose:lwin']
- Change the compose key in red to whatever you like.
- Put it back.
$ dconf load /org/gnome/desktop/input-sources/ < $HOME/Documents/gnomesettings.txt

Anfasa
16th December 2014, 02:35 AM
Hello,
I just tried the manipulation you suggested, but it didn't change anything.
The corresponding line in the file looks like this, with the part that I added in red.


xkb-options=['grp:alts_toggle', 'eurosign:e', 'caps:capslock', 'esperanto:colemak', 'kpdl:dotoss', 'terminate:ctrl_alt_bksp', 'ctrl:aa_ctrl', 'compose:rctrl']


However, my right control key still behaves as a normal one, whereas my Alt-Gr one is still stuck as a compose key... It looks like the settings haven't changed at all. (I tried restarting my computer as well, but it didn't fix anything).

This is really annoying since it prevents me from typing most standard characters, like the antislash, the pipe, or the square/rounded brackets...

dobbi
16th December 2014, 03:31 PM
You removed the ctrl:aa_ctrl to make it work?


$ cat /usr/share/X11/xkb/rules/xorg.lst | egrep -i aa_ctrl
ctrl:aa_ctrl At bottom left

Anfasa
16th December 2014, 09:49 PM
Yes, for some reason it made it work... Thanks for the help!

dobbi
17th December 2014, 01:02 AM
My guess is that "at bottom left" should really read "CTRL key mapped to bottom left" LoL

What could also work is changing the aa_ctrl to ac_ctrl(bottom right)