PDA

View Full Version : NVidia Linux driver manual install + Fedora 21 = quiet NVidia GTX 980 fans + high res



Jeff72
13th December 2014, 01:11 AM
NVidia Linux driver manual install + Fedora 21 = quiet NVidia GTX 980 fans + high resolution

Fedora 21 version installed: Fedora-Live-Workstation-x86_64-21-5.iso
NVidia Linux x86_64/AMD64/EM64T driver installed: NVIDIA-Linux-x86_64-343.36.run
Download the NVidia "Linux x86_64/AMD64/EM64T" 343.36 driver here: http://www.nvidia.com/object/unix.html
Graphics card I am using: Gigabyte GV-N980G1 GAMING-4GD (http://www.gigabyte.us/products/product-page.aspx?pid=5208#ov)


DO THIS AT YOUR OWN RISK. THE BELOW WORKED FOR ME, BUT I AM NOT AN EXPERT ON THIS MATTER AND AM LIMITED TO THE INFORMATION BELOW.


Note: All commands are run as root.

Install the pre-requisites:
yum install gcc kernel-devel

Blacklist the default nouveau graphics driver by creating /etc/modprobe.d/blacklist.conf:
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

Add "rd.driver.blacklist=nouveau" to middle of "GRUB_CMDLINE_LINUX=" line in /etc/sysconfig/grub
Example line from /etc/sysconfig/grub:
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rd.driver.blacklist=nouveau rhgb quiet"

Activate blacklist change:
grub2-mkconfig -o /boot/grub2/grub.cfg

Remove default nouveau driver:
yum remove xorg-x11-drv-nouveau.x86_64

Set computer to boot to run level 3 (non-graphical boot) and reboot:
systemctl set-default multi-user.target
reboot

Install the NVidia NVIDIA-Linux-x86_64-343.36.run driver:
chmod +x NVIDIA-Linux-x86_64-343.36.run
sh ./NVIDIA-Linux-x86_64-343.36.run
accept license
install 32bit compatibility
allow it to update your xorg.cfg file

If successful, then:
Set computer to boot to run level 5 (graphical boot) and reboot:
systemctl set-default graphical.target
reboot

Enjoy!


The information at the below web link by "Duke Nukem" was helpful in getting the above to work for Fedora 21:
"Step by step instructions: Fedora 20, NVIDIA GPU"
http://setiathome.berkeley.edu/forum_thread.php?id=74094


KERNEL UPDATES:
If you update your kernel, then the new kernel will not by default have the NVIDIA driver enabled.
You can reinstall the NVIDIA driver after updating your kernel and rebooting by doing the following:
Ctrl + Alt + F2 (this will get you a login)
Login as root
sh ./NVIDIA-Linux-x86_64-343.36.run
accept license
install 32bit compatibility
allow it to update your xorg.cfg file (might not be needed)
reboot

Note: I recent kernel update seemed to remove the blacklist file. You may have to do this again and then reboot and then do the above update section after a kernel update:
Blacklist the default nouveau graphics driver by creating /etc/modprobe.d/blacklist.conf:
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

marek
14th December 2014, 02:01 AM
You should change the initial prep (setp 1) to the following:

Install the pre-requisites:
yum install gcc kernel-devel-$(uname -r)

Loki1950
14th December 2014, 02:33 AM
You might want the get CUDA working as well just got it running myself the yum way ;) check my thread CUDA on F21 for a link to an nVidia how to for both their .run scripts and distro pkg managers 'buntu,Debian,SLES and few others as well.you also get VDPAU hardware codec decoding enabled.

Jeff72
19th December 2014, 08:49 PM
Added KERNEL UPDATES section at the end for when you install a new kernel and the NVIDIA driver is no longer enabled.

crokett
30th March 2015, 09:18 PM
You should add to the instructions that you need to generate a new ramdisk after you blacklist nouveau. I've done this on two systems using F21 and had to create new ramdisk images on both before it would quit loading the nouveau driver.

Jeff72
30th March 2015, 09:39 PM
You should add to the instructions that you need to generate a new ramdisk after you blacklist nouveau. I've done this on two systems using F21 and had to create new ramdisk images on both before it would quit loading the nouveau driver.

Did you create the blacklist file as mentioned in the first posting?

I did realize this recently, and added a note to the bottom of the first posting too:
Note: I recent kernel update seemed to remove the blacklist file. You may have to do this again and then reboot and then do the above update section after a kernel update:
Blacklist the default nouveau graphics driver by creating /etc/modprobe.d/blacklist.conf:
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

crokett
2nd April 2015, 12:48 AM
Yes, I did the blacklist and rebooted. On 2 different systems the nouveau driver was not removed until I generated a new ramdisk and rebooted again.