PDA

View Full Version : X crashing and resetting - with solution



werebear3
12th December 2014, 10:47 PM
Just after I upgraded to the 3.17 kernel my system started crashing. After the PC was running for a random amount of time all my windows in various virtual desktops would all go to one desktop and the top of the windows would disappear. Some times the screen would go black and it would come back for a while.

I tried a lot of things like running gnome instead of my regular KDE, deleting the amd driver so it would go to a generic driver but nothing worked. I knew Ferdora 21 was coming so I waited and did a fresh KDE install. No good same problem.

I checked x.org lof files and tried a few things but no go.

Solution.

I had bought a new mouse, a Razer DeathAdder. I unplugged my old mouse next to my PS2 port and ran windoze, downloaded the drivers and everthing worked great, the mouse is much more accurate. I never thought this would effect my Linux O/S.

Back to Fedora and after looking at the logs again and some bus errors I checked the mouse and saw it was set to 2x acceleration. I set it to 1x and my system stabilized. I plugged the mouse into one of the higher speed USB ports and put it back to 2x and voila no problems.

I guess the more accurate mouse was overloading the slower USB port at a guess, anyway if anyone else is having a similiar problem it's worth a try.

werebear3
17th December 2014, 04:18 PM
OK, that didn't work.

My newly installed Fedora 21 w/ KDE from downloaded Live spin crashes contantly. This system will run for various amounts of time and a logout and back in will get me running for a little while. I run 4 virtual desktops and when it crashes all my open windows move to one destop and the tops of the windows disappear. The menus are still there and they work but the top prt which allows you to close the window is gone. Also the arrow keys work while in the menus but the keyboard won't type. This started after a yum update about a week bedore 21 came out.

I have a ATI 7870 video card which still seems to work all right when gaming in Windows. I ran all the diagnostics I could find but can't find anything.

Any suggestions?

dobbi
17th December 2014, 05:33 PM
You may find some clues in the /var/log/messages

Try this.

$ su -
# egrep -i "freeze|lock" /var/log/messages

If nothing shows up, you have to look inside the whole log file.

werebear3
24th December 2014, 04:45 PM
Thanks for the suggestion, but the problem has gone away.

I'd like to the thank the mesa maintainers who with their last release have turned my Fedora 20/21 workstation back into the joy it usually is!