PDA

View Full Version : [SOLVED] Relatively fresh install, huge desktop icons



mvandemar
11th December 2014, 09:29 PM
I had to reinstall my system this past Monday. I backed everything up, wiped the drive completely, and then reinstalled. I ran the updates, installed cinnamon, installed some programs I use on a regular basis, and then copied back some config and data files from the backup (evolution, Zim wiki, maybe a few others). The next time I looked at my desktop it looked like the attached screenshot, where the icons are huge, ~175px wide. I can resize them individually if I want, but what I would like to know is what could have caused this, and how I can fix it across the board, if possible. Any ideas?

Thanks.


-Michael

lightman47
11th December 2014, 09:41 PM
- not mentioned was WHAT you re-installed.

had you previosly installed video drivers?

etc.

;-)

mvandemar
11th December 2014, 09:47 PM
- not mentioned was WHAT you re-installed.

had you previosly installed video drivers?

etc.

;-)

Not with this installation. Here is my yum history:



ID | Command line | Date and time | Action(s) | Altered
-------------------------------------------------------------------------------
28 | update | 2014-12-10 18:06 | Update | 1
27 | install unetbootin | 2014-12-10 12:50 | Install | 2
26 | install htop | 2014-12-10 10:13 | Install | 1
25 | install audacity-freewor | 2014-12-10 10:06 | Install | 2 <
24 | erase audacity | 2014-12-10 10:01 | Erase | 1 >
23 | install audacity | 2014-12-10 09:31 | Install | 4
22 | install gimp | 2014-12-10 03:29 | Install | 10
21 | install filezilla | 2014-12-09 18:53 | Install | 3
20 | install flash-plugin nsp | 2014-12-09 12:18 | Install | 2 <
19 | -y install geany | 2014-12-09 11:37 | Install | 2 >
18 | -y install bogofilter ev | 2014-12-09 11:25 | Install | 4
17 | install unrar | 2014-12-09 11:20 | Install | 1
16 | install hamster-time-tra | 2014-12-09 10:56 | Install | 3
15 | groupinstall Cinnamon De | 2014-12-09 10:36 | Install | 88
14 | install keepassx | 2014-12-09 10:27 | Install | 1
13 | install Zim | 2014-12-09 10:27 | Install | 1
12 | install cinnamon-desktop | 2014-12-09 10:15 | Install | 1
11 | install deluge | 2014-12-09 01:21 | Install | 43
10 | remove transmission | 2014-12-09 01:20 | Erase | 1
9 | install transmission | 2014-12-09 00:53 | Install | 4
history list


Pretty sure it happened on the morning of the 9th.

-Michael

lightman47
11th December 2014, 10:08 PM
Still not mentioned is WHAT you re-installed. Fedora 20, for instance?? Then, further questions include WHAT files/directories you "restored" from the backup.

You can't yet copy back executables and expect them to work. Programs need to be installed - they hook into SO many places, and only an 'install' does that.


.

mvandemar
11th December 2014, 10:25 PM
Sorry, Fedora 20. I know you can't copy programs back over, I am referring to files from ~/.config and ~/.cache, and again only specific to Filezilla, evolution, Zim wiki, and I think that was it.

Edit: also, this isn't just existing files. New files on the Desktop are also huge, and it does not appear to affect nemo or the regular file-roller.

-Michael

mvandemar
13th December 2014, 04:03 PM
I still haven't found a solution to this. Anyone have any ideas?

Thanks.

-Michael

antikythera
13th December 2014, 04:08 PM
I'm just wondering why you installed cinnamon twice? transaction 12 and 15 in the list? Given you statement as to when you guess the problem arose I'd say something got corrupted then.

If you are still struggling and no other suggestions I would start again from scratch (this time with Fedora 21) but just issue the groupinstall command you used for transaction 15. you shouldn't need to do both.

mvandemar
13th December 2014, 04:26 PM
Thanks, I did that because the first one didn't seem to do anything so I assumed it was the wrong command. I am undoing both now and then will re-intsall cinnamon and see if that helps.

Side question... for some reason now my sudo yum history shows Login user instead of Command line, any idea how to get it to switch back?


ID | Login user | Date and time | Action(s) | Altered
-------------------------------------------------------------------------------
35 | Michael ... <mvandemar> | 2014-12-13 10:17 | Erase | 14
34 | System <unset> | 2014-12-12 11:04 | Install | 10
33 | Michael ... <mvandemar> | 2014-12-12 10:58 | Install | 9
32 | Michael ... <mvandemar> | 2014-12-12 10:56 | Install | 57
31 | Michael ... <mvandemar> | 2014-12-12 10:54 | Install | 5
30 | Michael ... <mvandemar> | 2014-12-12 10:44 | Install | 1
29 | Michael ... <mvandemar> | 2014-12-12 10:00 | Update | 15
28 | Michael ... <mvandemar> | 2014-12-10 18:06 | Update | 1
27 | Michael ... <mvandemar> | 2014-12-10 12:50 | Install | 2
26 | Michael ... <mvandemar> | 2014-12-10 10:13 | Install | 1
25 | Michael ... <mvandemar> | 2014-12-10 10:06 | Install | 2 <
24 | Michael ... <mvandemar> | 2014-12-10 10:01 | Erase | 1 >
23 | Michael ... <mvandemar> | 2014-12-10 09:31 | Install | 4
22 | Michael ... <mvandemar> | 2014-12-10 03:29 | Install | 10
21 | Michael ... <mvandemar> | 2014-12-09 18:53 | Install | 3
20 | Michael ... <mvandemar> | 2014-12-09 12:18 | Install | 2 <
19 | Michael ... <mvandemar> | 2014-12-09 11:37 | Install | 2 >
18 | Michael ... <mvandemar> | 2014-12-09 11:25 | Install | 4
17 | Michael ... <mvandemar> | 2014-12-09 11:20 | Install | 1
16 | Michael ... <mvandemar> | 2014-12-09 10:56 | Install | 3

Edit: never mind on that one, figured out it is a yum configuration option, history_list_view.

-Michael

mvandemar
13th December 2014, 04:48 PM
I ran sudo yum history undo on both of the line items for cinnamon, which seems to have worked, but now when I try and reinstall it I get this:


$ sudo yum groupinstall "Cinnamon Desktop"
[sudo] password for mvandemar:
Loaded plugins: langpacks, refresh-packagekit
Maybe run: yum groups mark install (see man yum)
No packages in any requested group available to install or update

Is there any way to force a groupinstall?

-Michael

mvandemar
13th December 2014, 05:01 PM
And after following the instructions in this thread, I was able to get cinnamon reinstalled:

http://forums.fedoraforum.org/showthread.php?t=296735

With absolutely no change to the icons. :)

Could this be related to this issue?

https://github.com/numixproject/numix-icon-theme-circle/issues/1190

Edit: just to add, changing the theme does nothing to help the problem.

-Michael

antikythera
13th December 2014, 05:02 PM
did you try

yum groups mark install "Cinnamon Desktop"

EDIT - nevermind posted at the same time

could be that bug

mvandemar
19th December 2014, 06:13 AM
I just realized it's not only the icons, the background is huge as well. Does that sound like anything anyone has seen before?

Thanks.

-Michael

dobbi
19th December 2014, 06:58 AM
$ egrep -i icon /usr/share/themes/Adwaita/metacity-1/metacity-theme-3.xml
<!-- color of the button icons -->
<constant name="C_icons_focused" value="gtk:custom(wm_title,gtk:fg[NORMAL])" />
<constant name="C_icons_pressed" value="gtk:text[SELECTED]" />
<constant name="C_icons_unfocused" value="blend/gtk:text[NORMAL]/gtk:bg[NORMAL]/0.9" />
<constant name="C_icons_unfocused_prelight" value="blend/gtk:bg[NORMAL]/gtk:fg[NORMAL]/0.3" />
<constant name="C_icons_unfocused_pressed" value="blend/#000000/gtk:bg[NORMAL]/0.7" />
<constant name="C_icons_shadow" value="gtk:custom(wm_title_shadow,gtk:base[NORMAL])" />
<constant name="D_icons_unfocused_offset" value="0" /> <!-- offset of the unfocused icons -->
<constant name="D_icons_shrink" value="3" /> <!-- increasing this value makes the icons in buttons smaller -->


There appears to be a formulaic process to it.


x1="(width-width%3)/3+D_icons_shrink-D_icons_grow" y1="(height-height%3)/3+D_icons_shrink-D_icons_grow"

Now which one is about the desktop icons?
Don't know, but if you find it, you find what it is using to calculate the size of it and then you can check those parameters to see what it is causing it.

DPI? wrong xrandr info?


$ cat /etc/X11/Xresources
! This is the global resources file that is loaded when
! all users log in, as well as for the login screen

! Fix the Xft dpi to 96; this prevents tiny fonts
! or HUGE fonts depending on the screen size.
Xft.dpi: 96

Wrong value in some setting?

<distance name="title_vertical_pad" value="15"/> <!--
This needs to be 1 less then the
title_vertical_pad on normal state
or you'll have bigger buttons -->

journalctl should have some messages.

Broken session cache somewhere?

$HOME/.config/gnome-session/saved-session

bob
20th December 2014, 12:40 AM
mvandemar, Leigh emailed me this solution (since he's no longer a Forum member):


The solution to http://forums.fedoraforum.org/showthread.php?t=301902 is to set reset "icon view defaults" in nemo preferences to 100%.

nemo / edit / preferences / view tab reset "icon view defaults"

or run this as standard user


gsettings set org.nemo.icon-view default-zoom-level 'standard'


For those of us who know Leigh, his solutions are gold ! Give it a try.

mvandemar
20th December 2014, 06:25 AM
mvandemar, Leigh emailed me this solution (since he's no longer a Forum member):


For those of us who know Leigh, his solutions are gold ! Give it a try.

Brilliant! It worked! Thanks! :D

(please let Leigh know, and thank him for me!)

-Michael