PDA

View Full Version : Failed to mount /boot/efi in multi-boot environment



noloader
11th October 2014, 05:26 AM
I have Fedora 20 installed on a multiboot machine. The other OSes are Windows 8, Ubuntu and Debian. I think Ubuntu currently controls grub (due to the purple background).

The laptop worked fine and was off for about 3 months. Yesterday I pulled it off the shelf for some testing and updated all the OSes. Now I'm faced with the following when booting Fedora (from /var/lob/boot.log):

[FAILED] Failed to mount /boot/efi.
See 'systemctl status boot-efi.mount' for details.
[DEPEND] Dependency failed for Local File Systems.
[DEPEND] Dependency failed for Relabel all filesystems, if necessary.
[DEPEND] Dependency failed for Mark the need to relabel after reboot.

I'm not surpsied its having problems with /boot/efi because there is nothing in it (its literally empty). Fedora's gear appears to be located in /boot/grub2/x86_64-efi.

What is the best or recommended way to fix things so that Debian and Ubuntu can coexist with Fedora? (I *thought* I had it solved by not allowing Ubuntu to install their bootloader to /dev/sda, but the installer put it there anyways).

Is there some sort of rivalry here such that Ubuntu want to break Fedora? I've had problems with Ubuntu doing this for some time, and they continue to do it (cf., https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1118358).