View Full Version : How to make Desktop icons more visible in Cinnamon with certain themes

17th August 2014, 05:12 AM
Quite a few times, certain themes cause the text of desktop icons to be colored black while running in Cinnamon. There is a simple fix for that problem that doesn't involve changing the original theme files (and which changes can be overwritten in later updates to the original files). This way your setting also can be backed up the standard ways. Just do the following:

Create a file named gtk.css in your ~/.config/gtk-3.0 directory.
Put the following text in that gtk.css file:

.nemo-desktop.nemo-canvas-item {
color: #FFFFFF;
text-shadow: 1px 1px @desktop_item_text_shadow;
Alt+F2, type nemo -q and hit Enter
Alt+F2, type nemo -n and hit Enter

The text of the icons on the desktop should change to white instead of the default black color and should work across themes. You can change the color of the font and you also can add other options to change things like highlighting color, and so forth. Hope this helps and works for others as it does for me. I have tested it in F21 rawhide/branched and find it works there as well.

15th December 2014, 12:24 AM
This was very helpful! Thanks

15th December 2014, 10:47 AM
You're welcome. Glad that it helped.

26th February 2015, 06:31 PM
Great. Thanks. Helped me with my first Cinnamon installation.

26th February 2015, 08:00 PM
Glad it still helps.