PDA

View Full Version : Crackling from my mic when using VoIP



Spara06
31st May 2014, 06:49 PM
I'm using FC20 w/ Cinnamon and experiencing strange sound issues. Playback of the sound itself is completely fine but when I'm using either Skype or Google Hangouts, the person on the other end can hear some crackling sounds from my mic (almost like vinyl popping). I have a friend who just started using Zorin 8 and the same problem occurs on his end (I can hear . Is there some tweaking of PulseAudio that needs to be done or something? Should I be using a different audio server like Jack? Maybe it's buffer underruns or something like that? When I try and record my voice using Audacity, I hear no problems. I've heard this is due to the fact it uses the ALSA device directly instead of going through PulseAudio.

Any direction on where to start would be much appreciated!
Thanks

weitjong
1st June 2014, 05:36 AM
Both Alsa and PulseAudio have their own input volume gain settings. Have you tried to reduce the input volume gain in the PulseAudio sound setting? For my USB webcam, I find it to work best if I set PulseAudio gain to "Unamplified" and only control the volume gain via the Alsamixer. Of course, it will still crack when the gain is set too high on Alsa side. The crack is likely caused by the volume envelope max out.

Spara06
1st June 2014, 06:21 AM
Sorry, this may come off as a stupid question but how do I access the seperate volume controls? I can only find one volume mixer on my taskbar but I'm not sure which one it is.

weitjong
1st June 2014, 06:35 AM
I am not using Cinnamon but I suppose the one in the panel (task bar) is for PulseAudio. The ALSA input gain can be set by using a standalone app such as alsamixer.

Spara06
1st June 2014, 06:41 AM
When I move the levels in PulseAudio, it automatically adjusts them in the alsamixer. Therefore, they are the same controls, so I can't make them different

weitjong
1st June 2014, 07:57 AM
In Alsamixer you can choose which settings are you controlling by pressing F6. In general you will not want to control PulseAudio via Alsamixer. Use F6 to select your USB webcam device instead.

Sent from my SM-T215 using Tapatalk