PDA

View Full Version : WD My Book External Hard Disk - Lost and Found



weitjong
23rd May 2014, 02:54 PM
First I have a funny story to tell. I have an old 1T external HD which I use as my portable backup disk for all my (Linux) PCs and Macs. A few months ago I have accidentally dropped the thing from a desk height. It was not powered on then, so I didn't bother to check. So, yesterday I was a little bit shock and disappointed that the partitions were not showed up when I tried to connect it. Only a little because I am not losing any valuable data because the data are still available in their original sources.

So, what so funny about it? I am not ready to give up on the disk yet because it cost me an arm and leg back then for an external terabyte disk. So, I kept poking it using numerous disk utility tools, but still to no avail. All reported that I had a disk I/O error. Even a simple dd command to overwrite sector 0 also gave me this same error message. What kept me going was, some of the time after a power cycle the partitions could be detected again but immediately gave I/O error after attempting to mount and read them. Until I have a lucky break, I dropped the damn thing again one more time from a desk height!

I don't know how to explain it but I am able to read from it afterwards. I have played a few video media files from the disk and have unencrypted my encrypted files using encfs/fuse without any error. So far smartctl short tests have not found anything wrong with the disk. I have issued a long test just now and will only know the result a few hours later. The smartctl -H gives the disk a passed result. However, the -a option does show there are a few errors occurred at disk power-on. See attached.

I need some expert advice on those errors in the attached log. Are they critical?

Skull One
23rd May 2014, 03:59 PM
Outch! Outch! Outch!
I think that the first shock moved the drive from its connector, enough to provoke bad contacts, and hence an I/O error.
The second shock moved it back. It would be better to open the case (without breaking it!) and replug the drive.

weitjong
26th May 2014, 06:07 AM
Thanks for your reply. Your explanation sounds plausible. The long offline test completed without any error. There are 33 bad blocks in total, otherwise SMART overall assessment says the disk is OK. I do not expect it to be as good as new, of course. Still, I am curious about those last five errors in the attached smartctl -a result.


Error 14156 occurred at disk power-on lifetime: 5641 hours (235 days + 1 hours)
Error 14155 occurred at disk power-on lifetime: 5641 hours (235 days + 1 hours)
Error 14154 occurred at disk power-on lifetime: 5641 hours (235 days + 1 hours)
Error 14153 occurred at disk power-on lifetime: 5641 hours (235 days + 1 hours)
Error 14152 occurred at disk power-on lifetime: 5641 hours (235 days + 1 hours)

The error numbers on the left is quite large. Since only the last five are shown, I don't know how many of those errors are the repeat of the same error. I suppose the disk internal "online" clock has stopped after the first drop. The repeated errors could be the results from my repeated attempts to resurrect the disk. Now the disk is back "online" after the second drop, I can see the disk lifetime counter start counting again.


$ sudo smartctl --all /dev/sde |grep -i power_on_hours
9 Power_On_Hours 0x0032 093 093 000 Old_age Always - 5675

And there are no other errors occurred since 5641 hours. which I reckon it is a good sign. Having said that, I have decided to re-purpose this external drive for backing up other stuffs that I won't even shed a single tear when it eventually dies on me. I will permanently place this portable drive now in a safe place next to my "old and fat" PS3 but with a brand new firmware which I am sure will put the 1TB to good use :p.