PDA

View Full Version : Loss of Sound in F20 after Muting a Flash Application



bob p
19th May 2014, 07:03 PM
I've suddenly lost sound in F20 and I'm at a loss for figuring out how to restore it. I've had sound working just fine, no problems whatsoever. I haven't performed any recent updates or changed any configurations.

That said, I have used the mute button on a flash application around the time that things stopped working.

I'm at a bit of a loss for how to re-enable sound. I'm using KDE on F20, and the tools available in System Settings > Multimedia > Audio and Video Settings are not at all helpful.

I'd appreciate any guidance on what to check for, as it seems that something is muted somewhere. Unfortunately, as linux is becoming more and more like that other software product, more interfaces are being developed which hide what's going on from the user, and I can't seem to find the right configuration file to edit.

Thanks in advance.

marko
20th May 2014, 12:20 AM
Try installing the PulseAudio Volume Control (package named: pavucontrol )

Just install pavucontrol, then go to the Multimedia application folder in KDE and run it.

Sometimes the output gets set to headphones when it should really go to speakers or
vis versa. So just start up pulse audio volume control, go to the "output devices" tab and try changing the "Port" to the right output if it's wrong.

lsatenstein
20th May 2014, 12:37 AM
I have had similar experience. My video card came with digital audio interface, and the mother board with an analogue interface.
If you choose the wrong default, you will not have sound.

The second problem which I resolved was the default audio volume settings. It was low enough to make the normal sound inaudible. Moving the "slider" to the right resolved that second problem. In the audio setup, you can choose between cling, bark, and other sounds for system noises. Look at the settings before looking elsewhere.

bob p
22nd May 2014, 09:20 PM
I got it fixed.

I did a de-install / re-install which didn't help -- presumably because the same botched config files were being retained.

I ended up having to add the system tray to the taskbar, as there was no other way for me to access the mixer function via the GUI, and I didn't know which config file to edit. (I don't normally use a system tray as it just takes up space.) Once I found that speaker output was muted in the system tray, I un-muted it. That didn't help. Still no sound.

After changing the config settings I still had no sound -- It took a hard reboot before the new system settings worked on the kernel.

The need for a hard reboot surprised me.

Thanks for your help.

marko
26th May 2014, 06:45 PM
You probably would have gotten by with:



pulseaudio --kill
pulseaudio --startand not really needed the reboot

I've recently been noticing some weird PA problems where Firefox will play sound but then VLC will
not unless I close Firefox and then restart Pulseaudio with the above on command line.