PDA

View Full Version : Help With Keyboard Mapping on F20



goodmuyis
10th May 2014, 04:47 PM
Good all,

Am a fedora fans and of recent am able to get fedora 20 install on my laptop, but on Windows am able to get a Software to configure and assign non functioning to another key. The problem is on my Acer Lapton both CTRL keys not working so assign Left CTRL to ALT. I have read about Xmodmap i which i had to create a .Xmodmap and .xmodmaprc and place them in home dir but no solution. the line below is what i have in those file


keycode 64 = Control_L

Pls note that a new fedora/Linux

Thanks

anika200
10th May 2014, 05:37 PM
What desktop are you running KDE or Gnome? If you are using KDE you can change the interaction with Ctrl key from >> keyboard settings >> advanced >> Ctrl key position.

flyingfsck
10th May 2014, 06:00 PM
Here you go:
https://wiki.archlinux.org/index.php/xmodmap

goodmuyis
10th May 2014, 10:14 PM
What desktop are you running KDE or Gnome? If you are using KDE you can change the interaction with Ctrl key from >> keyboard settings >> advanced >> Ctrl key position.

I Curiously install with Gnome

@flyingfsck i have read that in one of on this tread http://forums.fedoraforum.org/showthread.php?t=297845

But i still can get it working, kindly help
=========
Modify: Want i wanted to do is to convert the LEFT_ALT to function as LEFT_CTRL (Both CTRL are not working)

flyingfsck
11th May 2014, 04:12 AM
OK, here is something I just did:
http://www.aeronetworks.ca/2014/05/fedora-on-mac-change-cmd-key-to-ctrl-key.html

As above, you need two steps: First remove the key binding you don't want, then assign it the way you want.

goodmuyis
11th May 2014, 01:36 PM
Thanks for your assistance, I will try that on VirtualBox because last night i reinstall F20 with KDE Destop Environment and am able to easily swap Windows Key with CTRL.

I think my problem is am unable to properly use the Xmodmap and what to put in the file.
If am able to do that on VBox i will mark the Tread as Solve

Thanks once again