PDA

View Full Version : [SOLVED] F20 KDE Touchpad Stops Working After Splash Screen



buddhistpalm
3rd May 2014, 05:02 PM
I am running F20 with xfce and KDE on an Asus X551MA laptop. The (Elantech) touchpad works in xfce, and it tracked okay in KDE until I enabled tapping and assigned tap gestures to mouse clicks in System Settings > Input Devices > Touchpad.

Afterward, the touchpad worked as if I had the sensitivity set to -100 ---I had to push as hard as possible without actually 'clicking' the touchpad, and even then it barely moved--- and it didn't work any better after I set the touchpad settings to 'Default'. Rebooting, updating yum, and shutting down had no effect.

Here's the catch: the touchpad works fine (no tap-to-click) at the login screen, and is still functional during the KDE splash screen. It only stops working after loading into the actual KDE desktop.

Any thoughts?

Dan
3rd May 2014, 05:23 PM
Here's the catch: the touchpad works fine (no tap-to-click) at the login screen, and is still functional during the KDE splash screen. It only stops working after loading into the actual KDE desktop.

Try adding this to your /etc/X11/xorg.conf.d/ folder. Name the file, "50-synaptics.conf".



Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
Option "VertEdgeScroll" "1"
EndSection

# This option enables the bottom right corner to be a right button on
# non-synaptics clickpads.
# This option is only interpreted by clickpads.
Section "InputClass"
Identifier "Default clickpad buttons"
MatchDriver "synaptics"
Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
Identifier "Disable clickpad buttons on Apple touchpads"
MatchProduct "Apple|bcm5974"
MatchDriver "synaptics"
Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection

# Quirks for special touchpads

# Force clickpad on for wireless trackpad. The propbit isn't set on 3.3.
# Remove once we're on 3.4
Section "InputClass"
Identifier "Disable clickpad buttons on Apple touchpads"
MatchProduct "Apple Wireless Trackpad"
MatchDriver "synaptics"
Option "ClickPad" "on"
EndSection

# Some devices have the buttons as part of the lower edge of the
# touchpad. Pressing a button moves the cursor, causing cursor jumps and
# erroneous clicks.
# Use the synaptics area property to work around this, udev labels these
# devices for us as touchpad_button_overlap.
# Affected: Dell Mini
Section "InputClass"
Identifier "touchpad button overlap"
MatchIsTouchpad "on"
MatchTag "touchpad_button_overlap"
Option "AreaBottomEdge" "4000"
EndSection

buddhistpalm
3rd May 2014, 07:50 PM
That fixed the lack of tap-to-click at the login screen, but the touchpad still lacks all functionality when KDE loads beyond the splash screen. I can move the cursor in the splash screen (while all the icons are loading at the bottom of the screen), but not after the desktop appears.

buddhistpalm
3rd May 2014, 07:58 PM
I found an old forum thread here: http://forums.fedoraforum.org/archive/index.php/t-263709.html. I just copied the text of one user's /home/[user]/.kde/share/config/kcmtouchpadrc and put it into mine, which seems to have solved the problem. All touchpad and tapping functionality have been restored.

Thanks for the help!