PDA

View Full Version : Backlight control and fans on Acer Aspire S3-391



rsboone
13th March 2014, 02:24 AM
Hi, all. I've just installed Fedora over Xubuntu. Everything's gravy except the backlight control, which I can't adjust, and the fans, which are constantly running. It's running Intel graphics, and in Xubuntu, I was able to get the backlight control working by adding this to Grub:


GRUB_CMDLINE_LINUX="quiet splash pcie_aspm=force i915.i915_enable_rc6=1 acpi_osi=Linux acpi_backlight=vendor"

In Fedora, it doesn't work. I've also tried every edit listed on the Linlap site for the S3, and the Grub edit listed in these forums, to no avail. (edit: apparently I can't enter urls in the forums? (edit: for some reason(?), I can't post links here, so here's a link to both of the links: http://notepad.cc/plaliga24)

Since it's worked before, I assume all I need is the right Grub parameter, but I'm certainly no expert on them. This is a rather big deal- I love what I've seen out of Fedora so far, but my (already weak) battery can't take the 7.5W the backlight's pulling right now (Xubuntu was totaling about that for the entire system, after some tweaks).

The fans may be another matter, but anyone with enough knowledge to help me with the backlight may be able to help with the fans (again, I didn't have the problem with the running fans in Xubuntu, either). I hope it goes without saying that any help is greatly appreciated.

fbsduser
13th March 2014, 06:00 AM
can you provide the output of uname -a and of your .config file (it's in your /boot folder along with the kernel) for both the Xubuntu you where using (you can get them from a LiveUSB) and the Fedora you're using ATM. That info might help in identifying why Xubuntu supports your backlight better than Fedora.

rsboone
13th March 2014, 01:47 PM
I wish I'd had the foresight to copy the config *before* I installed Fedora, but I installed it over Xubuntu. Hopefully the Fedora config can provide something:

Here's uname:


Linux localhost.localdomain 3.11.10-301.fc20.x86_64 #1 SMP Thu Dec 5 14:01:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux


and the config is here (http://pastebin.com/6M6WnWxR).