PDA

View Full Version : Network connection gone since bought new router



Ingenuitas
10th March 2014, 03:35 AM
Bought a new router, TP-Link TL-WR841N. Since the day I plugged it in, my Fedora machine will no longer connect to internet. Windows machine didn't have a problem with new router. I have reset the router, re-booted the router, changed the NIC in the Fedora machine. Network manager says that it is connected but no web page will open. The light on the router is on but it isn't blinking. I have no idea what to do. I never expected a problem like this from a Linux OS. I also have a PC-BSD machine and it is connecting to internet with new router. Any ideas?

Fedora box has static IP of 192.168.1.3

It can ping the router and the other computer on the network

It can ping 74.125.227.105 (google) but it will not open in a browser. (Firefox)

resolv.conf returns:
#Generated by NetworkManager
nameserver 192.168.1.1
nameserver 207.69.188.186
nameserver 207.69.188.187

I can access the router's web configuration page. It shows that the Fedora box connected as 192.168.1.3

LongTimeDabbler
10th March 2014, 03:56 AM
Can you ping the DNS server(s)? what happens if you set the DNS to 8.8.8.8 (google dns)?

Ingenuitas
10th March 2014, 04:10 AM
I can ping the dns servers and I set the dns server to 8.8.8.8 and this didn't change anything.
When I open the router page it shows the Fedora box connected. But I haven't seen a web page on the Fedora machine since last October when I installed the new router.

---------- Post added at 11:10 PM ---------- Previous post was at 11:08 PM ----------

Are TP-Link routers just Linux unfriendly? I am at wit's end here. Do I just need to buy another router? None of this makes any sense to me. Networking is the absolutely last thing I'd ever have imagined Linux to have a problem with.

marko
10th March 2014, 04:19 AM
see the procedure in my post #5 in thread here

http://forums.fedoraforum.org/showthread.php?t=295449

some router/dialers have trouble with systems that try IPv6 DNS,
Firefox will try IPv6 DNS before v4, flipping that about:config flag to true
will stop that.

Another quick way to test this is to try a non-Firefox browser, try konqueror, chrome, chromium
If it works then it's the firefox IPv6 issue

Another thing to try is to go to the router admin page and point the DNS servers to opendns.org 's
or to google's, some ISP's have really poor dns service

google dns
8.8.8.8

opendns:
208.67.222.222
208.67.220.220

Ingenuitas
10th March 2014, 04:33 AM
Did all of that, not working.

ocratato
10th March 2014, 04:35 AM
From what you have described it does not appear that there is anything wrong with the Fedora box - it can see the router's web page, for example. This leaves some configuration problem in the router.

Some random thoughts:

The IP you have assigned to the Fedora machine is possibly a bit low - it might conflict with a DHCP assigned address - make sure you have specified a fixed range in the router.

Have you made the router aware of your fixed IP, and double checked the MAC that you used?

LongTimeDabbler
10th March 2014, 04:40 AM
What if you do away with the static ip on fedora and let the dhcp work as it does in most cases? Just a thought...

marko
10th March 2014, 05:49 AM
Ideas:
1) try a different browser --> prove it's not Firefox's fault
2) try traceroute:

traceroute google.com

does the traceroute show the traffic gets to google?

3) go in the router admin page and hard set the DNS servers to a different dns like opendns or google dns. You sort of said you tried that but I'm not sure if you're talking about the dns in /etc/resolv.conf or the router (which seems to show you pointing to the router AND earthlink dns's). I'd suggest setting the dns server in the router/dialer to something different.

4) Make sure you renegotiate the connection (tell networkmanager to drop and reconnect to the router), don't just make changes on the router and not reload the connection in NM

I also like LongTimeDabbler's idea

Sineath
11th April 2014, 10:12 PM
Solved. Bought new router. Linksys wired. Changed nothing, just disconnected the TP-Link, reconnected everything to the Linksys. Fedora machine online.