PDA

View Full Version : My mouse configuration changes are not persistent



Mathy
19th February 2014, 03:28 PM
Hello, just registered here. I usually find the fixes I need for the issues I have on Fedora in this forum, or simply figure them out myself.
Unfortunately, I can't seem to find a solution for this.

I used to be a gamer not so long ago, and I still use my Razer DeathAdder. The problem here is that:
-I dislike mouse acceleration.
-it's too sensitive.

So I wrote a little shell script to fix these two.


xinput set-prop "Razer Razer DeathAdder" "Device Accel Velocity Scaling" 1 ;
xinput set-prop "Razer Razer DeathAdder" "Device Accel Profile" -1 ;
xinput set-prop "Razer Razer DeathAdder" "Device Accel Constant Deceleration" 3.5 ;


And put it in /etc/profile.d so I wouldn't have to run it with bash each time I logged in.

It does work, but as soon as I open the terminal (I'm on KDE, using Konsole) it goes back to it's high sensi and possibly turns on mouse accel too.


Any hints on what's causing this and how to fix it?


Thank you for your time,
Mathy

kldixon
19th February 2014, 04:59 PM
As far as I am aware, the definitive reference for pointer acceleration is:
http://xorg.freedesktop.org/wiki/Development/Documentation/PointerAcceleration/#Introduction
The values I use are:


$ cat /etc/X11/xorg.conf.d/50-mouse-deceleration.conf
Section "InputClass"
Identifier "My Mouse"
MatchIsPointer "yes"
# some curved deceleration
# Option "AdaptiveDeceleration" "2"
# linear deceleration (mouse speed reduction)
Option "ConstantDeceleration" "2"
# Option "AccelerationProfile" "0"
# Option "AccelerationScheme" "predictable"
# Option "VelocityScale" [real]
# Option "ExpectedRate" [real (Hz)]
# Advanced Options
# Option "VelocityTrackerCount" [integer]
# Option "VelocityInitialRange" [integer]
# Option "VelocityAbsDiff" [real]
# Option "VelocityRelDiff" [real]
# Option "VelocityReset" [integer]
# Option "Softening" [boolean]
# Option "AccelerationProfileAveraging" (boolean)
EndSection

dobbi
19th February 2014, 05:22 PM
I know of 3 ways:

- On the desktop manager find where those configurations are stored in KDE, system settings can configure those things.
- On udev creating rules for your mouse.
- On the xorg.conf.d(the new xorg.conf)

You can also try the program xkbset(in the repositories) that saves the changes to the xsession.
Also in KDE you can save those actions in the Device Actions settings.


Resources:
http://docs.kde.org/development/en/kde-workspace/kcontrol/mouse/index.html
http://userbase.kde.org/System_Settings/Device_Actions
http://userbase.kde.org/Tutorials/Mouse_pointer_settings_for_large_displays
https://www.centos.org/docs/4/html/rhel-rg-en-4/s1-x-server-configuration.html (see: 7.3.1.6. InputDevice)

Mathy
19th February 2014, 06:01 PM
Didn't work.
I went to System Settings->Startup and Shutdown->Autostart and put my .sh script there.
I rebooted, and as soon as the session started, Kate (the text editor) tried to open, and I could not use the the lower panel at all, nor could I launch anything.
Why is this so hard to configure is beyond me. A simple GUI with sliders would fix all my problems. Should I try the KDE support forums?

UPDATE: Removed the xset line from the end of the script. Changed accel profile from None to -1.