View Full Version : Unable to modify lid close behavior

18th February 2014, 07:08 AM
Hey y'all,

I did a fresh install of Fedora 20 64-bit with GNOME on my Acer Aspire 5750g laptop and wanted to make it so that, when I closed the lid of the laptop while it was plugged in, only the display would turn off and the laptop wouldn't suspend (having the laptop lock would be fine by me as well), since I often leave the laptop on when downloading large files.

The problem is, when I close the lid, the display does turn off, but there's no way to turn it back on. It doesn't come on when I move the mouse/trackpad, press keys or press the power button. All I can do is reboot

At any rate, I looked for the option in d.conf editor, but found nothing. Then I entered this command:

gsettings set org.gnome.settings-daemon.plugins.power lid-close-battery-action nothing

I got the following error, with no change in the problem

No such key 'lid-close-battery-action'

Next, I edited /etc/system/logind.conf. I uncommented the HandleLidSwitch line and changed it from suspend to ignore and then lock, rebooting for each change. I also uncommented LidSwitchIgnoreInhibited. The problem persists

So how can I change this behavior? If the absence of that key is a problem, how do I solve it?

18th February 2014, 09:04 AM
KDE seems to have an override to systemd handling the lid close. When my lid is closed when shutting down, the moment it leaves the environment is when it suspends. Otherwise it seems to let KDE dictate what happens when the lid closes. You may be able to find out what they do and setup a service to handle the lid switch at all times.

18th February 2014, 09:34 AM
Oh, I should have mentioned, I'm using GNOME