PDA

View Full Version : Cinnamon showing all directory icons



rholme
9th February 2014, 05:35 PM
I have two users on a newly installed Fedora 20 with Cinnamon on top of Gnome.

One ME is an administrator

The other is not

I like the new (optional) icons for home, computer and trash - NICE.

But for the 2nd person - they get icons for every directory in their top home directory.
I do not get these and would prefer they do not show for the other person.

I do not see anyplace to turn this off.

Suggestions?

--

PS - Do NOT install Cinnamon directly from the disttr DVD - add it on with yum afterwards.
I had a several problems.

leigh123linux
9th February 2014, 06:40 PM
If it's nemo drawing the desktop icons (default is false)


gsettings set org.nemo.desktop volumes-visible false


It's likely your cinnamon install has the misfortune to have nautilus drawing the icons (default is true)


gsettings set org.gnome.nautilus.desktop volumes-visible false


and to prevent it from intruding (default is false).


gsettings set org.gnome.desktop.background show-desktop-icons false

rholme
9th February 2014, 10:13 PM
Thanks - will try all three commands

rholme
9th February 2014, 10:31 PM
Oops premature thanks. You tried and I ran all three commands AFTER running the get equivalent and seeing that at least one of these settings was TRUE. Now using "get" - they are all false.

I logged the user out and back in as no change happened when logged in. NO CHANGE.

I ran the gets again to make sure - all three settings are false.

Thanks for your thoughts and efforts but as my 2 yr. old grandson says "It isn't working".

:=[

rholme
10th February 2014, 03:48 PM
OK, further research reveals that in both fedora 18 and 20 the second one is true, the other two false (well the first - org.nemo.desktop volumes-visible is not in fedora 18 at all so i guess it is FALSE :=]]] ).

Anyway both myself (and my wife) had false/true/false set in fedora20 these extra icons (reminding me of friends and the ugly Windoze desktops littered with icons to the point of useless) showup for my wife (non admin) and NOT for me (admin).

Changing the second setting for both of us had no effect:
I still see no icons (thank you very much)
but she does (boo hoo hoo) - They only confuse things

I hope someone can figure out why they are coming up.

rholme
10th February 2014, 05:10 PM
for the record - Leigh put me on a roll

gsettings list-recursively | grep desktop | grep icon | grep true | sort | uniq

reveals that there is ONE setting that eliminates this pain

gsettings set org.nemo.desktop show-desktop-icons false

This gets rid of ALL of them RIGHT AWAY (including the three ones I liked, but I can live with that).

I could find NO other setting which I could turn off and keep the three which I found nice
( home, computer, trash)
At lease it is acting like the Cinnamon I used under fedora18. :=<]

rholme
11th February 2014, 01:42 AM
Interesting note - last 64 bit install acted consistently for the two users. Gsettings command works for both nicely.

Don't know why one system showed only a few icons. STRANGE.

rholme
13th February 2014, 05:46 PM
This is my last post on this one. It makes no sense at.

I have access to 3 fedor20 freshly installed systems, each with 2 users, two are 64 bit and 1 is 32.

The 32 bit system acts "nice" for both users, One 64 bit system acts nice for one user (admin==me), all other accounts had to have the following command run: gsettings set org.nemo.desktop show-desktop-icons false

Now these accounts show NO icons (trash, computer and home). The only real question is why they are different. I installed them the same way. I did a thorough look using gsettings list-recursiively and found no notable differences.

Too bad.