PDA

View Full Version : start Xfce power manager at login?



techsupport
26th January 2014, 02:16 AM
The old way to run files used to be rc.local

if it's a service we can run it through systemctl

But what is the current standard method to load a program we want to be running at user login?

xfce4-power-manager

the desktop is LXDE

PabloTwo
26th January 2014, 02:44 AM
You can't run a desktop program from the rc.local file due to the fact that the rc.local file is executed before anyone actually logs in and thus before there is any desktop environment even running.

You autostart applications by using the DE's session autostart function. In Xfce, that would be, in Xfce's menu, Applications > Settings > Session and Startup. If you install the Xfce DE, the power manger progam (xfce4-power-manger) is one of the default system-tray apps that is already setup to autorun. It is designed to run in the xfce4-panel, and I would suspect it wouldn't install itself into an LXDE panel due to incompatibilities.

xfce4-power-manager is not a stand-alone GUI program that runs in it's own window. It's an xfce panel app.

sidebrnz
26th January 2014, 04:03 AM
Since you're running Xfce, as do I, here's what you do: from the Main Menu, you go to Settings->Session and Startup and select the tab marked Application Autostart. If xfce4-power-manager is listed but not selected, select it; if it's not listed, add it.

jonnycat
27th January 2014, 03:39 AM
I put mine in the /etc/xdg/lxsession/LXDE/autostart fille (as "@xfce4-power-manager"). Some other (general LXDE autostart) locations I have seen referenced are:

/etc/xdg/openbox/autostart
/etc/xdg/autostart
~/.config/openbox/autostart.sh
~/.config/autostart

techsupport
27th January 2014, 04:02 AM
...

It is designed to run in the xfce4-panel, and I would suspect it wouldn't install itself into an LXDE panel due to incompatibilities.

xfce4-power-manager is not a stand-alone GUI program that runs in it's own window. It's an xfce panel app.

I am running it and it is on the panel in LXDE.

---------- Post added at 02:58 AM ---------- Previous post was at 02:57 AM ----------


I put mine in the /etc/xdg/lxsession/LXDE/autostart fille (as "@xfce4-power-manager"). Some other (general LXDE autostart) locations I have seen referenced are:

/etc/xdg/openbox/autostart
/etc/xdg/autostart
~/.config/openbox/autostart.sh
~/.config/autostart
.....

Thanks

---------- Post added at 03:02 AM ---------- Previous post was at 02:58 AM ----------


Since you're running Xfce, as do I, here's what you do: from the Main Menu, you go to Settings->Session and Startup and select the tab marked Application Autostart. If xfce4-power-manager is listed but not selected, select it; if it's not listed, add it.

No, I am running LXDE