PDA

View Full Version : How to: Install Fedora 20 on Lenovo Yoga 11s and setting up wifi



syltman
6th January 2014, 04:45 PM
Hello, here I provide you with the neccessary steps as to how to set up Fedora 20 on Lenovo yoga 11s. This is my first tutorial and english isn't my native language but hopefully it's easy enough to understand.

NOTE THAT WITH LINUX KERNEL 3.15 THE WIRELESS MODULE IS INCLUDED BY DEFAULT SO ODDS ARE FOR FEDORA 21 THE WIFI STEPS ARE UNNECESSARY

Note:
When opening the lid the laptop doesn't wake up properly so you'll have to press some key to wake it up.
"Tablet" mode does not work by default. If you go into tablet mode the only thing that is disabled is the keyboard. However if you're using gnome 3 you can install an extension called touchpad indicator (found here: https://extensions.gnome.org/extensi...pad-indicator/ ) and then deactivate the touchpad and enable on screen keyboard when going into tablet mode as a workaround.

1 Installation
Download the Fedora 20 DVD and NOT the regular Fedora 20 Desktop Edition. It can be found here: https://fedoraproject.org/en/get-fedora#formats .
Burn the disk to either a USB or DVD.
Resize the Windows Partition by using the Disk Management tool.
Download the ZIP containing the wifi driver and put it in either a seperate DVD/USB or use the same one. The wifi driver can be downloaded here: https://github.com/lwfinger/rtl8723au/archive/master.zip .
Windows 8.1 requires OEM's to enable Secure Boot. This must be disabled (don't worry this is not gonna put your computer in any danger and you can still boot windows). In order to do this you must go into BIOS.
Grab a pencil or something thin and sharp. Then reboot and next to the power button there should be a small button. Press that button before boot has started and then a menu should pop up, select BIOS Setup.
From there find the Secure Boot in Configuration tab and disable it.
Go to Exit and save configuration and then reboot. Press the small buttom again and this time from the menu select Boot Menu. From the Boot Menu select the USB.
The Fedora installer should prompt so follow those steps from there. Reboot when done.
Voila! Now it's time to install the WIFI drivers.


2 Setting up WIFI

Move over rtl8723au (the wifi driver) downloaded before and extract it somewhere in your Home folder. In this tutorial I'll assume you put it in the Documents folder.
Mount the installation USB and take note of the path. In the file manager of Gnome 3.10 you can do this by inserting the USB and then selecting the USB in the files and then press CTRL + L to find the location it was mounted on.
Open up a terminal. Here comes the more difficult parts.
Run the command:


sudo vi /etc/yum.repos.d/media.repo

Type in your password. Press 'i' to insert text and type in the following:


[InstallMedia]
name=Fedora20Media
baseurl=file://REPLACETHIS
gpgcheck=0
enabled=0

Replace "REPLACETHIS" with the file location we acquired earlier.
Ok now press ESC and then type in
:wqThis will save the file and exit.
Almost there. Now type the following.
sudo yum --disablerepo=* --enablerepo=InstallMedia install kernel-devel gcc-c++ automake
This will install the necessary packages for compiling the wifi driver. When prompted if you want to continue type in 'y' and enter..
Phew! Almost there now. Time to go into the folder we extracted earlier. In the terminal type in:


cd Documents/rtl8732au-master/

then after that type these two commands. These commands will compile and install the wifi driver.


make
sudo make install

Note: The driver needs to be recompiled everytime a new kernel is out.


That's it! When you reboot now you should have working internet. Afterwards you can install the bluetooth driver (found with instructions) here: https://github.com/lwfinger/rtl8723au_bt. Also the brightness settings doesn't work by default, a guide to install them can be found here: http://www.forums.fedoraforum.org/showpost.php?p=1684870&postcount=6

slamo
16th January 2014, 06:16 AM
Thanks for this!

Any specific reason to use the the DVD version over the standard Live disk?

I've tested Korora (built from Fedora) and everything seems to work properly (minus Wifi/bluetooth/tablet) in live mode.

syltman
16th January 2014, 05:26 PM
Thanks for this!

Any specific reason to use the the DVD version over the standard Live disk?

I've tested Korora (built from Fedora) and everything seems to work properly (minus Wifi/bluetooth/tablet) in live mode.

Yes as you have to install the kernel-devel gcc-c++ automake packages locally in order to compile the wifi driver. They are afaik not included in the livecd. I'll not though that I don't know if Korora comes with the packages.
Also if you're using gnome 3 you can install an extension called touchpad indicator (found here: https://extensions.gnome.org/extension/131/touchpad-indicator/ ) and then deactivate the touchpad and enable on screen keyboard when going into tablet mode. I've edited this into my main post

slamo
17th January 2014, 03:01 AM
Yes as you have to install the kernel-devel gcc-c++ automake packages locally in order to compile the wifi driver. They are afaik not included in the livecd. I'll not though that I don't know if Korora comes with the packages.
Also if you're using gnome 3 you can install an extension called touchpad indicator (found here: https://extensions.gnome.org/extension/131/touchpad-indicator/ ) and then deactivate the touchpad and enable on screen keyboard when going into tablet mode. I've edited this into my main post

Got it, i'll check the live media tonight for Korora for anyone who may be interested. Thanks for the simple instructions regarding the wifi

slamo
17th January 2014, 06:10 AM
Yes as you have to install the kernel-devel gcc-c++ automake packages locally in order to compile the wifi driver. They are afaik not included in the livecd. I'll not though that I don't know if Korora comes with the packages.
Also if you're using gnome 3 you can install an extension called touchpad indicator (found here: https://extensions.gnome.org/extension/131/touchpad-indicator/ ) and then deactivate the touchpad and enable on screen keyboard when going into tablet mode. I've edited this into my main post

kernel-devel is included on the Korora live disk. lucky for me, I am able to wire tether through my phone for the other dependencies. I noticed that touchpad indicator extension can disable the touchpad during the event of a mouse being plugged in. Were you able to make it activate upon tablet mode? Or do you still have to manually shut of the touchpad? Not a big deal either way. atleast it's a work around. I can confirm the the keyboard shuts off automatically in Korora once in tablet mode

Thanks for the knowledge. :cool:

Gnome 3.10 runs beautifully as a touch DE on the 11S.

slamo
17th January 2014, 11:21 PM
Korora install went great. I played with Fedora as well. My kernel-headers had to be updated in able to install wifi.

Backlight didn't work for me out of the box (Both Fedora and Korora). The buttons appeared to work... the brightness bar would increase and decrease, but the brightness itself never changed.


I had to edit the grub file.



sudo gedit /etc/default/grub


by adding the following to the GRUB_CMDLINE_LINUX line:



i915.invert_brigthness=1 acpi_osi=Linux acpi_backlight=vendor


Save it and close.
Next had to create a Xorg configuration:



sudo gedit /etc/X11/xorg.conf


Copy, Paste, Save, and Close the following into gedit


Section "Device"
Identifier "Card0"
Driver "intel"
Option "AccelMethod" "sna"
Option "Backlight" "intel_backlight"
Endsection


After a restart, brightness controls worked great.

syltman
19th January 2014, 12:42 PM
Slamo: Thank you, I was gonna add that eventually. A bug also worth keeping an eye on: https://bugzilla.gnome.org/show_bug.cgi?id=709914.

Also on post #15 on http://ubuntuforums.org/showthread.php?t=2193327 they seem to have created a script to get the screen orientation properly set up on ubuntu. The script doesn't seem to work though so it's time to investigate.

edit: the problem seems to be that I can't get the event of switching the screen 360 degrees to be registered in acpi (doesn't show up in acpi_listen).

edit2: I also tried the same thing with udev but it doesn't register a removal of the keyboard either so I'm out of ideas.

jdgiotta
22nd January 2014, 05:14 AM
Have you noticed the touchpad key will not toggle it on and off, but it's recognized?
acpi_listen does not receive the input.

slamo
29th January 2014, 09:11 AM
Have you noticed the touchpad key will not toggle it on and off, but it's recognized?
acpi_listen does not receive the input.

The keyboard shuts off, but the touchpad does not. If you're using Gnome 3 use the following instructions as a workaround...



"Tablet" mode does not work by default. If you go into tablet mode the only thing that is disabled is the keyboard. However if you're using gnome 3 you can install an extension called touchpad indicator (found here: https://extensions.gnome.org/extension/131/touchpad-indicator/ ) and then deactivate the touchpad and enable on screen keyboard when going into tablet mode as a workaround.

Also, in accessibility option you can opt for an onscreen keyboard to pop up. It works decently enough, but I wouldn't recommend typing an essay with it.

I've been fishing around the Ubuntu Forums, for the mouse toogle but haven't found anything yet. They are still trying to get brightness keys working (as the fix in Fedora doesn't work for them), and their other main concern is auto rotate. In Fedora, the button is detected and shows the onscreen toggle when pressed, but the accelerometer is not working. There is a work around found in that forum, but I haven't played with it yet.

jdgiotta
29th January 2014, 03:37 PM
The keyboard shuts off, but the touchpad does not. If you're using Gnome 3 use the following instructions as a workaround...

I don't mean in tablet mode, I meant the F6 key. When used, the touchpad dialog pops up, but it never toggles.

slamo
29th January 2014, 07:02 PM
I don't mean in tablet mode, I meant the F6 key. When used, the touchpad dialog pops up, but it never toggles.

No, I understand. But there's no real fix yet. Just a workaround. If you're typing and the mouse keeps jumping around, use the above extension--because the Synaptic driver is horrible in Linux.

cyborg
13th July 2014, 11:52 AM
Hi Guys, thanks to everyone who's participated here, I've my 11s about a month and it's finally time to get Windows off.

After disabling secure boot, I can get the live iso to boot fine, but the install iso won't. After a long wait, I get cannot boot, /dev/root doesn't exist, starting dracut emergency shell. I got this before disabling secure boot with the live iso, and secure boot is still disabled because it says booting in insecure mode.

cyborg
13th July 2014, 02:23 PM
My bad, was dodgy install media.

cyborg
14th July 2014, 07:17 PM
Does anyone know if there's any support for multitouch and the orientation sensor?

florianmonfort
12th December 2014, 04:21 PM
Hi,

I'm experiencing some issues when trying to boot Fedora 21 Live USB on my Lenovo Yoga 2 13" laptop.

I already have Fedora 20 installed and I want to have a fresh install.

But when I plug in the USB key and boot, the computer seems to recognize the key but not to be able to boot anything because I remain on a black screen with a white underscore flashing.

It does not prompt me to the Fedora Boot start page where I can chose to start Fedora Live.

Plus I'm trying the USB Key on other laptops and Fedora boots pretty easily and fast.

I've tried formatting the Key both with Fedora Live USB creator and the dd command in a terminal.