PDA

View Full Version : yum extender error



occhipinti
26th September 2013, 07:59 AM
Hello,

I'm running 3.9.11-200.fc18.x86_64

I get the following error when I try updating my system using the yum extender:


23:54:13 : ERROR: Dependency resolving completed with errors
23:54:13 : ERROR: Package: kmod-nvidia-304xx-3.9.9-201.fc18.x86_64-304.88-1.fc18.4.x86_64 (rpmfusion-nonfree-updates)
Requires: kernel-uname-r = 3.9.9-201.fc18.x86_64
Removing: kernel-3.9.9-201.fc18.x86_64 (@updates)
kernel-uname-r = 3.9.9-201.fc18.x86_64
Installed: kernel-3.9.10-200.fc18.x86_64 (@updates)
kernel-uname-r = 3.9.10-200.fc18.x86_64
Installed: kernel-3.9.11-200.fc18.x86_64 (@updates)
kernel-uname-r = 3.9.11-200.fc18.x86_64
Available: kernel-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64
Installing: kernel-3.10.12-100.fc18.x86_64 (updates)
kernel-uname-r = 3.10.12-100.fc18.x86_64
Available: kernel-debug-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64.debug
Available: kernel-debug-3.10.12-100.fc18.x86_64 (updates)
kernel-uname-r = 3.10.12-100.fc18.x86_64.debug
23:54:13 : ERROR: Package: libdvdcss2-1.2.13-7.fc18.x86_64 (@atrpms)
Requires: /usr/sbin/ldconfig
Removing: glibc-2.16-33.fc18.x86_64 (@updates)
Not found
Updated By: glibc-2.16-34.fc18.x86_64 (updates)
Not found


I also get this error when I try installing xbacklight with the yum extender:

Dependency Resolution Errors:

Package: kmod-nvidia-304xx-3.9.9-201.fc18.x86_64-304.88-1.fc18.4.x86_64 (rpmfusion-nonfree-updates)
Requires: kernel-uname-r = 3.9.9-201.fc18.x86_64
Removing: kernel-3.9.9-201.fc18.x86_64 (@updates)
kernel-uname-r = 3.9.9-201.fc18.x86_64
Installed: kernel-3.9.10-200.fc18.x86_64 (@updates)
kernel-uname-r = 3.9.10-200.fc18.x86_64
Installed: kernel-3.9.11-200.fc18.x86_64 (@updates)
kernel-uname-r = 3.9.11-200.fc18.x86_64
Available: kernel-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64
Installing: kernel-3.10.12-100.fc18.x86_64 (updates)
kernel-uname-r = 3.10.12-100.fc18.x86_64
Available: kernel-debug-3.6.10-4.fc18.x86_64 (fedora)
kernel-uname-r = 3.6.10-4.fc18.x86_64.debug
Available: kernel-debug-3.10.12-100.fc18.x86_64 (updates)
kernel-uname-r = 3.10.12-100.fc18.x86_64.debugPackage: libdvdcss2-1.2.13-7.fc18.x86_64 (@atrpms)
Requires: /usr/sbin/ldconfig
Removing: glibc-2.16-33.fc18.x86_64 (@updates)
Not found
Updated By: glibc-2.16-34.fc18.x86_64 (updates)
Not found

Suggestions on how to resolve these issues please.

Thank you,

Occhi

george_toolan
26th September 2013, 08:25 AM
See http://forums.fedoraforum.org/showthread.php?t=294091

Furthermore the libdvdcss library seems to conflict with glibc. Try to remove libdvdcss, update your glibc and then re-install libdvdcss.

occhipinti
26th September 2013, 04:19 PM
In a terminal I typed in:

yum remove package libdvdcss

and got this result:

Running Transaction
Erasing : libdvdcss-1.2.13-7.fc18.x86_64 1/1
Verifying : libdvdcss-1.2.13-7.fc18.x86_64 1/1

Removed:
libdvdcss.x86_64 0:1.2.13-7.fc18

Complete


I then went back to yum extender to try and make the following updates and received the subsequent error message:


08:12:58 : YUM: --> Running transaction check
08:12:58 : YUM: ---> Package glibc.x86_64 0:2.16-33.fc18 will be updated
08:12:58 : YUM: ---> Package glibc.x86_64 0:2.16-34.fc18 will be an update
08:12:58 : YUM: ---> Package glibc-common.x86_64 0:2.16-33.fc18 will be updated
08:12:58 : YUM: ---> Package glibc-common.x86_64 0:2.16-34.fc18 will be an update
08:12:58 : YUM: ---> Package glibc-devel.x86_64 0:2.16-33.fc18 will be updated
08:12:58 : YUM: ---> Package glibc-devel.x86_64 0:2.16-34.fc18 will be an update
08:12:58 : YUM: ---> Package glibc-headers.x86_64 0:2.16-33.fc18 will be updated
08:12:58 : YUM: ---> Package glibc-headers.x86_64 0:2.16-34.fc18 will be an update
08:12:58 : YUM: --> Processing Dependency: /usr/sbin/ldconfig for package: libdvdcss2-1.2.13-7.fc18.x86_64
08:12:58 : YUM: --> Processing Dependency: /usr/sbin/ldconfig for package: libdvdcss2-1.2.13-7.fc18.x86_64
08:12:58 : YUM: --> Finished Dependency Resolution
08:13:00 : ERROR: Dependency resolving completed with errors
08:13:00 : ERROR: Package: libdvdcss2-1.2.13-7.fc18.x86_64 (@atrpms)
Requires: /usr/sbin/ldconfig
Removing: glibc-2.16-33.fc18.x86_64 (@updates)
Not found
Updated By: glibc-2.16-34.fc18.x86_64 (updates)
Not found



I may have confilcting glibc files. Here is the contents of a source folder I created where I downloaded and compiled a series of libraries in an attempt to fix another problem:

[root@localhost src]# ls
glib-2.36.1 libxml2-2.8.0.tar.gz
glib-2.36.1.tar.gz Magic Lantern
glib-2.36.1.tar.xz nautilus-dropbox-1.6.0-1.fedora.x86_64.rpm
libffi-1.20 rts5139
libffi-1.20.tar.gz rts5139.tar.bz2
libplist-1.10 soundkonverter-2.0.2-7.1.x86_64.rpm
libplist-1.10.tar.bz2 tor-browser_en-US
libplist-1.4 tor-browser-gnu-linux-x86_64-2.3.25-10-dev-en-US.tar.gz
libplist-1.4.tar.bz2 usbmuxd-1.0.7
libusb-1.0.9 usbmuxd-1.0.7.tar.bz2
libusb-1.0.9.tar.bz2 vuze
libxml2-2.4.6 Vuze_4900_linux.tar.bz2
libxml2-2.4.6.tar.gz xz-5.0.4
libxml2-2.8.0 xz-5.0.4.tar.bz2


Do I need to uninstall some of these packages? If so, what command do I use to vies a README file in terminal?

Thanks