PDA

View Full Version : xfig-3.2.5-36.b.fc19.x86_64 crashes SOLVED



BStsetson
14th August 2013, 07:33 PM
I had a bunch of old xfig files that crashed when I used the new xfig.
SOLUTION:
1. I got the .src.rpm,
2. Did a rpmbuild --rebuild with the
-O2
optimization changed to
-O1
and everything worked when I did this

1. yum erase xfig transfig

2. yum localinstall xfig.3.2.5-36.b.fc19.x86_64.rpm xfig-common-3.2.5-36.b.fc19.x86_64.rpm transfig-3.2.5d-10.fc19.x86_64.rpm
from the
/rpmbuild/RPMS/x86_64
directory

I got the idea when Sun workstations were crashing because of an optimization
flag optimizing too aggressively and causing Sun crashes.

Hilbert
22nd October 2013, 04:33 PM
I had this problem in Fedora 19 (x86_64). xfig crashed when asked to read the attached file. To implement the same fix (lowered optimization level) using the tarball:

download xfig.3.2.5c.tgz and transfig.3.2.5e.tar.gz from http://xfig.org
unpack them
make sure you have imake and the necessary X11 devel
libraries:

yum install imake libXt-devel libXpm-devel libXmu-devel Xaw3d-devel libpng-devel libjpeg-devel

In the xfig directory, following instructions in README,


xmkmf

Now, edit the Makefile, look for

CXXDEBUGFLAGS = -O2 -fno-strength-reduce -fno-strict-aliasing
CDEBUGFLAGS = -O2 -fno-strength-reduce -fno-strict-aliasing
and in each case change -O2 to -O1


make
make install.all