PDA

View Full Version : Get a Samsung ML-2510 working under fedora 19



Mattu
13th August 2013, 03:27 PM
After installing the Samsung ML-2510 on fedora 19 (using the USB port), I found that even though the printer seemed to be fully installed as per the recommended drivers, on testing the printer, it was generating zero prints.

The recommended driver when I installed the printer was being shown as the ML-2525w (even one of the 2550 drivers was shown as recommended at one time), but neither worked, they installed but no printing occurred even though the printer would wake up and make some noise, there was no printing going on.

Every time I sent a print job, the printer woke up if it was in sleep made some noises as if going to print, but then nothing.

Each time I noted the print queue message would appear at bottom right of screen, then it would close again.

On inspecting the print queue, I noted that all the print jobs were showing as completed, however it also showed the size of the documents printed were zero pages. Thus there were no error messages being generated because as far as Fedora was concerned the print job had completed successfully.

I looked for all the guides on installing Samsung printers but the only ones relating to the ML-2510 talked about installing the Samsung unified Linux drivers downloaded off the Samsung site. They described using the packaged installer supplied and then having to move files about because they are installed into the wrong locations as the location of printer drivers had changed since Samsung produced the Linux drivers for the 2510 back in 2009.

I was browsing a site which listed the contents of the Samsung Linux unified driver when I noticed the model printer mentioned in the consumables section was the ML-2010, so I wondered if Samsung had actually used the ML-2010 driver too.

So I set my printer to use the fedora supplied Samsung ML-2010 driver.

This time the printer worked.

So it seems the recommended driver for the ML-2510 should be the ML-2010 and none other.

Saved me a lot of work if I had gone ahead and downloaded the Samsung unified driver package.