PDA

View Full Version : Fedora 19 - enable magnet links in Firefox to use Transmission



Montclaire
13th August 2013, 02:18 PM
Wasted a couple of hours to enable magnet links in Firefox to use Transmission. A few links on the subject can be found around, also on this forum (here (http://forums.fedoraforum.org/showthread.php?t=245202)), but they were not 100% correct, or at least didn't work in my case, so here is how I got it working on Fedora 19 with GNOME:

Open Firefox, in address bar type about:config and add these boolean keys (rightclick->new->boolean):


network.protocol-handler.expose.magnet true
network.protocol-handler.external.magnet true
network.protocol-handler.warn-external.magnet false
(last key is bold because in the link above same key is set to true which does not work anymore)

Then, open terminal and run this:

gconftool-2 -t string -s /desktop/gnome/url-handlers/magnet/command "transmission-gtk '%s'"
gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/needs_terminal false
gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/enabled true
(bold was also missing in the previous link and also from tutorial on transmission page)

Now when you click on a magnet link it should automatically open Transmission and show the add torrent dialog.

It would be nice if someone knew how to do the same thing but to have Firefox ask you which application to use instead of directly open Transmission.

Noel Brookham
23rd August 2013, 02:47 AM
I'm new to Fedora thus a bigginer.

This process did not work for me, even failed after a reboot.

Upon clicking on a magnet link within Firefox, Application Launcher opens up.

I'm not sure what to do next???

pinkfloyd
23rd August 2013, 10:07 AM
Can this work?

https://addons.mozilla.org/en-US/firefox/addon/add-to-transmission/

Noel Brookham
25th August 2013, 11:26 PM
Pinkfloyd,

Thanks for the suggestion.

I finally discovered the problem, it's Firefox. Every time I click on the magnet link a Launch Application window pops up. You have the ability to choose the application but being so new to Fedora, I didn't know where to look.

But alas I found it /usr/bin and the program I selected was transmission-gtk, check the box to Remember my choice for magnet links.

If for some quirky reason you've made a mistake you can remove your association in Firefox Preferences, Applications, magnet, in the drop down box at the right, select Application details, Remove.