PDA

View Full Version : today's upgrade fails on package satyr



Jagcoxa
4th August 2013, 02:46 PM
hi,

there are a lot of upgrades today , and doing yum update results in:


error: Package: abrt-2.1.6-2.fc19.i686 (updates)
requires: satyr >= 0.5
available: satyr-0.3-2.fc19.i686 (fedora)
satyr = 0.3-2.fc19
Install: satyr-0.4-1.fc19.i686 (updates)
satyr = 0.4-1.fc19
Error: Package: libreport-2.1.6-2.fc19.i686 (updates)
requires: satyr >= 0.5
Available: satyr-0.3-2.fc19.i686 (fedora)
satyr = 0.3-2.fc19
Install: satyr-0.4-1.fc19.i686 (updates)
satyr = 0.4-1.fc19
Error:Package: abrt-2.1.6-2.fc19.i686 (updates)
Requires: satyr >= 0.5
Available satyr-0.3-2.fc19.i686 (fedora)
satyr = 0.3-2.fc19
Available: satyr-0.4-1.fc19.i686 (updates)
satyr = 0.4-1.fc19


in order to solve this, install:
http://kojipkgs.fedoraproject.org//packages/satyr/0.5/2.fc19/i686/satyr-0.5-2.fc19.i686.rpm
http://kojipkgs.fedoraproject.org//packages/satyr/0.5/2.fc19/i686/satyr-devel-0.5-2.fc19.i686.rpm
http://kojipkgs.fedoraproject.org//packages/satyr/0.5/2.fc19/i686/satyr-python-0.5-2.fc19.i686.rpm

and run yum update again

jtzero
4th August 2013, 05:08 PM
On a multilib system, you'll also need the same packages (but 64 bit) from here:
http://kojipkgs.fedoraproject.org/packages/satyr/0.5/2.fc19/x86_64/ (just skip the debuginfo package)
After installing all 6 rpms, I was able to continue with the update.

marko
4th August 2013, 05:11 PM
Or just slap on a "--skip-broken" and a wait for the packages in the repo to get fixed. The things missed didn't seem super important.. no big rush

deretsigernu
7th August 2013, 02:44 AM
What does satyr do? I'm using Apper/Plasma Desktop and it says this package needs to be installed. I tried internet search for satyr and got no useful results. In addition, the update says I need to install fros and I don't know what that is and an internet search has no meaningful results.

Ell02
7th August 2013, 03:07 AM
No one has said thank you yet,so I will.
Thank You Jagcoxa.

jtzero
7th August 2013, 04:21 PM
What does satyr do? I'm using Apper/Plasma Desktop and it says this package needs to be installed. I tried internet search for satyr and got no useful results.
From it's description in yum, "Satyr is a library that can be used to create and process microreports", and is a dependency for the Automatic Bug Reporting Tool (abrt), which lead to the OPs error.


In addition, the update says I need to install fros and I don't know what that is.....
I wouldn't worry much about this one. It's installed on my PC, doesn't seem to be a dependency of anything, and won't even run (at least from the command line, though maybe that's not supposed to be how it's used). It's a screencasting front-end, so maybe someone who actually does that would know more about it.


......and an internet search has no meaningful results.
Apper and 'yum info' can help too :)


Or just slap on a "--skip-broken" and a wait for the packages in the repo to get fixed. The things missed didn't seem super important.. no big rush
I'll disagree with you here only because I was troubleshooting another issue, and any error deserves to be tracked down.


No one has said thank you yet,so I will.
Thank You Jagcoxa.
Indeed, Thank you Jagcoxa.

Aarbron
10th August 2013, 12:36 PM
Hello all,

I found this thread the other day and was going to enact the solution provided by Jagcoxa. However, today, II didn't have to do anything, it seems to have resolved itself.

In any case, thanks for providing the solution, Jagcoxa. The failed package was beginning to drive me to distraction!

Jagcoxa
10th August 2013, 02:11 PM
you are wellcome :):)