PDA

View Full Version : [SOLVED] Fedora 17 VirtualBox 4.2.12 installation error.



kbdeamon
25th July 2013, 05:58 AM
Hello everyone,

I am attempting to install VirtualBox by following instructions that I have found online (e.g., http://www.dalescott.net/mediawiki/index.php/How_to_install_VirtualBox_on_Fedora_17_(64_bit)

I have run all the necessary updates such as yum update and I am currently running


# uname -r
3.9.10-100.fc17.x86_64


yum update suggests that there is nothing else to update


# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
No Packages marked for Update


When I attempt to run VirtualBox installation, I get the following results:



# yum install VirtualBox
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package VirtualBox.x86_64 0:4.2.12-1.fc17 will be installed
--> Processing Dependency: VirtualBox-kmod = 4.2.12 for package: VirtualBox-4.2.12-1.fc17.x86_64
--> Processing Dependency: libgsoapssl++.so.2()(64bit) for package: VirtualBox-4.2.12-1.fc17.x86_64
--> Running transaction check
---> Package gsoap.x86_64 0:2.8.7-2.fc17 will be installed
---> Package kmod-VirtualBox.x86_64 0:4.2.12-1.fc17.7 will be installed
--> Processing Dependency: kmod-VirtualBox-3.8.13-100.fc17.x86_64 >= 4.2.12-1.fc17.7 for package: kmod-VirtualBox-4.2.12-1.fc17.7.x86_64
--> Running transaction check
---> Package kmod-VirtualBox-3.8.13-100.fc17.x86_64.x86_64 0:4.2.12-1.fc17.7 will be installed
--> Processing Dependency: kernel-uname-r = 3.8.13-100.fc17.x86_64 for package: kmod-VirtualBox-3.8.13-100.fc17.x86_64-4.2.12-1.fc17.7.x86_64
--> Finished Dependency Resolution
Error: Package: kmod-VirtualBox-3.8.13-100.fc17.x86_64-4.2.12-1.fc17.7.x86_64 (rpmfusion-free-updates)
Requires: kernel-uname-r = 3.8.13-100.fc17.x86_64
Installed: kernel-3.3.4-5.fc17.x86_64 (@anaconda-0)
kernel-uname-r = 3.3.4-5.fc17.x86_64
Installed: kernel-3.9.10-100.fc17.x86_64 (@updates)
kernel-uname-r = 3.9.10-100.fc17.x86_64
Available: kernel-debug-3.3.4-5.fc17.x86_64 (fedora)
kernel-uname-r = 3.3.4-5.fc17.x86_64.debug
Available: kernel-debug-3.9.10-100.fc17.x86_64 (updates)
kernel-uname-r = 3.9.10-100.fc17.x86_64.debug
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


I suppose that it would also be helpful to note that I installed a number of audio/video codecs for MP3 and DVD playback. However, I am not sure if that has an impact on the current installation failure.

I just don't understand the error "Error: Package: kmod-VirtualBox-3.8.13-100. . . ." or how to go about fixing it. Can anyone suggest a solution please?

I have looked through the forum, but since I am pretty clueless with respect to this I may have not recognized that some posting had the solution that I am looking for.

adionahigh
25th July 2013, 07:04 AM
Hi,

I remember facing issues with the Virtual Box install sometime back myself.

Can you get the rpm and install it off of here - https://www.virtualbox.org/wiki/Linux_Downloads

glennzo
25th July 2013, 10:47 AM
Start by rebooting into the newest kernel. Then try installing VirtualBox and see what errors you get, if any.

kbdeamon
25th July 2013, 07:19 PM
Hi adionahigh,

your suggestion seems to have worked and virtualbox installed.

Hi glennzo,

I do not quiet understand what you mean, as I attempted my installation after a reboot.

I still do not understand that error but perhaps it is linked to other strange post-update behavior.

Should I create a new thread for it? If so, which part of the forum? The following continues to occur:

After updating the machine and installing NVIDIA drivers (which installed successfully) my XFCE randomly become non-responsive in that I can launch applications from the launch bar at the bottom and from a terminal. However, I cannot move/close/manipulate those applications view GUI, neither the application window or desktop responds to left/right mouse clicks, I cannot switch application focus, I cannot close or minimize these applications and sometimes after restarting my screensaver activates on logon.

In fact the only thing that I can do is issue a killall -u command to logout and relog back in but there is no guarantee that relogging solves this issue.

Any input would be greatly appreciated.

glennzo
26th July 2013, 09:54 AM
The error
Package: kmod-VirtualBox-3.8.13-100.fc17.x86_64-4.2.12-1.fc17.7.x86_64 (rpmfusion-free-updates)
Requires: kernel-uname-r = 3.8.13-100.fc17.x86_64
means that installation of kmod-VirtualBox-3.8.13-100.fc17.x86_64 depends on you running a matching kernel version. You are currently running kernel version 3.9.10-100.fc17.x86_64. That doesn't match the version of kmod-VirtualBox that yum is proposing to install. I don't have anything running Fedora 17 so I can't check for myself but it looks like there are 2 options. Reboot to kernel 3.8.13-100 and try again or wait for kmod-VirtualBox version 3.9.10.100 to become available.

Actually there's a third option. While running the newest kernel, completely remove kmod-VirtualBox and try installing akmod-VirtualBox instead.

I do have Fedora 17 installed through VirtualBox on my Fedora 19 system. The kernel version for that installation of Fedora 17 is 3.9.10-100 and there is a matching version of kmod-VirtualBox available.

kbdeamon
1st August 2013, 09:02 PM
Hi glennzo

thank you very much for the clarification. I have reinstalled the system and this time the virtualbox installation went through without a glitch. I will keep this in mind but I am still not very sure as to how to go about make sure that all my software is up to date without breaking the system.

I'll mark this particular thread as solved. Thank you so much.