PDA

View Full Version : PS3 dualshock 3 controller and F19



matthewjavelet
15th July 2013, 03:22 AM
it seems i am having issues with getting my ps3 controller to work using f19 64bit and the latest 3.9.9-302 kernel with a usb connection.

i've installed joystick and made sure i had kernel-modules-extra installed which i did before even trying to plug it in. after a fresh boot after installing the packages, i plugin my stuff, see that js0 and js1 were created in my /dev/input folder and tried to run:

jscal -c /dev/input/js0

when it asked for some input from the controller i went ahead and did so and noticed that it wasnt picking up any commands i had issued.

ran demsg |grep input as well and it shows the ps3 controller and everything.

if anybody could point me in the right direction that would be much appreciated.

MadmanRB
15th July 2013, 03:51 AM
I have had mixed results with PS3 controllers in linux in general.
And well I hate to say this but you may want to invest in a wired Xbox 360 controller.
Sure Microsoft but after having many issues with the PS3 controller under linux the xbox controller proves the better.
If its one thing i give credit to Microsoft is that they do make most of their devices non OS specific.
I know right, you would think their products would benefit only windows, but I have actually had better experience with Microsoft hardware under linux then i do with say... logitech.
Sometimes life is weird like that.

matthewjavelet
15th July 2013, 04:18 AM
i know life is weird but life isn't a program so i don't really think that statement applies. also thanks for the advice but i'll go with the procedural method and troubleshoot my issue first before doing any of that.

i guess the need for clarification on my situation is in order. i already have my controller working just fine on my windows partition. i do all my programming on fedora and sometimes instead of booting into windows just to play some zelda for 20 minutes i'd like to stay in fedora.

Since I believe fedora core 5 or maybe f9? i cant remember. ps3 controller support has worked out of the box. meaning i could just plug it in and go. well now that's not longer the case and i'd just like to try to get it working since i don't think too much effort would be required. the issue is mainly my lack of knowledge.

matthewjavelet
16th July 2013, 02:55 AM
it appears the game gods have blessed me and bestowed the gift of happiness. the controller now works. the solution will remain a mystery for generations to come.