PDA

View Full Version : [SOLVED] Slow boot after upgrade to F19



sidebrnz
14th July 2013, 09:28 PM
Yesterday evening, I upgraded my laptop from F17 to F19. There were a few, minor hiccups, but on the whole it went well. However, booting is odd: the first part, with the Fedora logo goes very nicely. Then, the screen goes blank and there's a long wait before lightdm comes up. (I use Xfce, not Gnome.) Once I log in, there's another delay before the desktop comes up properly. Systemd-analyze shows that my machine boots in just under 27 seconds, but I have a panel widget that (among other things) shows uptime, and from the time it starts until I have a working desktop is about two minutes, and this wasn't true before the upgrade. Everything in /var/log/boot.log seems OK, but I find this in /var/log/messages:

Jul 14 13:02:23 barrayar dbus-daemon[320]: dbus[320]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Unit dbus-org.freedesktop.nm-dispatcher.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.nm-dispatcher.service' for details.

This is repeated several times. Checking, there is no dbus-org.freedesktop.nm-dispatcher.service, which explains why it "fails." Does anybody here know how to track down what's causing this and correct it? As far as I can tell, once everything's up and running it works well, but I'd like to clear this up. It's kind of hard to use your laptop as a Linux showpiece it it's that laggy at boot!

raveit65
15th July 2013, 12:19 AM
I'm pretty shure you run in this issue with selinux, as you described the issue.
https://bugzilla.redhat.com/show_bug.cgi?id=972881 comment 49
Try as root:
restorecon -R -v /usr/sbin

If this works, report your experience to the report, to wake up selinux maintainer.

DBelton
15th July 2013, 01:07 AM
That was a bug in NetworkManager that hit upgrades.

Try running:



su -
(root password)

systemctl enable NetworkManager-dispatcher.service


Reboot or start the service manually after enabling it.

sidebrnz
15th July 2013, 11:16 PM
I tried your suggestion first Dan, because it seemed simpler. After enabling the service, I rebooted. No change, except that for some odd reason, my Xfce desktop had no icons. Also, it occurred to me to watch the disk activity: during the blank time before lightdm came up and after I logged in but before things started to work, the disk light was off at all times. Then I tried the restorecon suggestion and rebooted again. No blank period, no hanging, proper disk activity, and when I had my desktop up, my uptime was just under one minute. (Yes, I have icons; I'm sure that wasn't related, especially as I didn't undo Dan's suggestion.)

Thanx to both of you, and I'm now off to Bugzilla to add my tuppence to the discussion.

DBelton
16th July 2013, 05:29 AM
I usually set SELinux to permissive when I do an upgrade. I set to permissive, upgrade, do a complete relabel, then set back to enforcing.

I guess that's why I didn't see the problem you had during my upgrade to F19.

gerryrbd
17th July 2013, 05:39 AM
WOW I had been having very long wait times on F19 before and after session login for weeks and these fixes cut down both! Now the system boots to desktop in only seconds rather than minutes, thank you!