PDA

View Full Version : Autologin does not work



firefexx
7th July 2013, 12:38 PM
Hi,

I have done a fresh F19 install with Cinnamon.

I want to enable autologin because the login screen is useless since I use hard disc encryption.

My first attempt was to toggle the switch in the user config menu, see screenshot below (sorry, its german, but I think you know this window)
http://s1.directupload.net/images/130707/q2imykqt.png

Unfortunately it does not work. Maybe because I use Cinnamon and the display manager which is installed when choosing Cinnamon Desktop during system installation (doesn't look like GDM). :confused:

Is there another way to enable autologin or do you have some suggestions to fix the problem?

sea
7th July 2013, 01:04 PM
Not knowing which loginmanager Cinnamon uses, all i can suggest is a workaround, using LXDM instead.

su
yum -y install lxdm
sed s/"#autologin=dgod"/"autologin=firefexx"/g -i /etc/lxdm/lxdm.conf

However, i'm not aware how to change the used login screen the new official way, as i'm used to change it in /etc/sysconfig/desktop
This is no longer the case.

hth

firefexx
7th July 2013, 03:28 PM
Just got it :)

The default display manager is lightdm.

# /usr/libexec/lightdm/lightdm-set-defaults --autologin=username