PDA

View Full Version : cannot run alsamixer? No sound control? Fix



icebox
4th July 2013, 12:53 AM
Hi, in Fedora 18 KDE my sound finally works on my laptop (sony vaio vpceb2).:cool:

But alsamixer cannot run (even under root) and there is no kmix icon to control the sound :doh:
The phonon tab in Multimedia under KDE System settings also hangs.

Well this is definitely not very user friendly. (so fedora is not suitable for my parents yet.)
Anyway disabling SELinux resolved this issue for me:


sed -i s/SELINUX=enforcing/SELINUX=disabled/g /etc/selinux/config && reboot

And pray that the developers fix this bug soon.

Als if you search sound mixer and right click on KMix you can add it to your taskbar where it belongs.
After that; everything works fine, and you can control your sound on KDE.

Gareth Jones
4th July 2013, 01:10 AM
Have you tried forcing a relabel?

su -c "touch /.autorelabel"
and reboot, then re-enable SELinux.

No guarantees, but sometimes the labels seem to get left behind by updates, and nine times out of ten a relabel has fixed SELinux errors for me.

icebox
4th July 2013, 02:10 AM
Edit: I remove .pulse and the problem magically disappeared.