PDA

View Full Version : Fedup F18 -> F19 with encrypted root partition? Make sure you have rd.luks.uuid!



mmmmm
3rd July 2013, 02:58 PM
When upgrading from Fedora 18 to Fedora 19 and you have a LUKS encrypted root partition, make sure that the kernel parameters for the old F18 boot entry in your grub2.cfg contain the correct rd.luks.uuid.

if it doesn't, the upgrade boot will run into a Dracut emergency shell, saying that /dev/mapper/luks-<some GUID> does not exist.

So your old F18 kernel command line part of the boot entry should look similar to this:

linux /vmlinuz-3.9.6-200.fc18.x86_64 root=/dev/mapper/luks-<a GUID> ro quiet rhgb ... rd.luks.uuid=luks-<the same GUID as before> ...

Fedup will copy these parameters to the upgrade command line. It is required for F19, but wasn't really necessary for F18.
Adding the rd.luks.uuid parameter fixed it for me.

If you missed the chance and already ran into the problem, it's sufficient to change it after the fedup run:

Mount the boot partition and open grub2/grub.cfg in an editor. If you don't know how to do it from the emergency shell, just start F18 and load /boot/grub2/grub.cfg into an editor.
Locate the upgrade boot entry and the kernel ("linux") command line in it
Duplicate the root=luks-<something> parameter, replacing "root" by "rd.luks.uuid"
Save the file
Reboot to the upgrade
.
Good luck!

When you know the solution, it's easy to find others who had the same problem before, see bugs 974000 (https://bugzilla.redhat.com/show_bug.cgi?id=974000) and 968540 (https://bugzilla.redhat.com/show_bug.cgi?id=968540) (probably a duplicate of the first one).

By the way - I don't remember having ever dropped the rd.luks.uuid parameter as suggested in the first Bugzilla entry.

Hope that helps somebody.

pnelsonsr
7th July 2013, 09:48 PM
Oh yeah it helped... Thanks! Here (http://forums.fedoraforum.org/showthread.php?p=1659090&posted=1#post1659090) is my post that has links to the bugzilla bug report.

mmmmm
8th July 2013, 10:09 PM
Here (http://forums.fedoraforum.org/showthread.php?p=1659090&posted=1#post1659090) is my post that has links to the bugzilla bug report.

More importantly, this part of your post (http://forums.fedoraforum.org/showpost.php?p=1659152&postcount=8) shows what exactly to do in the LVM case, which I my short-cut procedure didn't cover.

Your boot command line didn't contain a root=/dev/mapper/luks-* parameter, so there was nothing in the grub configuration to copy the UUID from and you had to look it up somewhere else.

Thanks!

pnelsonsr
9th July 2013, 12:50 AM
Your boot command line didn't contain a root=/dev/mapper/luks-* parameter, so there was nothing in the grub configuration to copy the UUID from and you had to look it up somewhere else.
Yeah that one threw me for a bit trying to figure out what was the correct UUID to use.