PDA

View Full Version : Compiz on Fedora 18 with MATE



Ihatewindows
20th April 2013, 05:19 PM
People keep saying that Compiz is dead. Compiz is not dead. You can still install it on Fedora with MATE, XFCE, LXDE, etc.

I made it fairly straight forward, just copy/paste the commands in a terminal and run them.

For MATE:


sudo yum install compiz compiz-mate compiz-bcop compiz-manager compiz-plugins-main compiz-plugins-extra compiz-plugins-unsupported compizconfig-python libcompizconfig ccsm fusion-icon

XFCE:


sudo yum install compiz compiz-xfce compiz-bcop compiz-manager compiz-plugins-main compiz-plugins-extra compiz-plugins-unsupported compizconfig-python libcompizconfig ccsm fusion-icon

LXDE:


sudo yum install compiz compiz-lxde compiz-bcop compiz-manager compiz-plugins-main compiz-plugins-extra compiz-plugins-unsupported compizconfig-python libcompizconfig ccsm fusion-icon

One thing you will notice is that Compiz will not start automatically. You can change that if you want in your settings. You should be able to run Compiz in MATE by going into Applications >> System Tools >> Compiz Fusion Icon. That starts Compiz in MATE. The process should be similar for XFCE. To configure Compiz, go to System >> Preferences >> CompizConfig Settings Manager. You should see the Emerald controls in there too.

To make it look a little bit like the previous versions of Fedora that used Gnome 2 and Compiz, I included an Emerald theme: Clearlooks 2. Looks neat, and for me, I can easily tell if I am running Compiz or not. (I run the regular Clearlooks without Compiz.)

http://fedorafiles.yolasite.com/resources/76183-clearlooks-2-blend.emerald

Once downloaded, run it, and Emerald should pop up with the new theme installed, double click it to apply it.

---------- Post added at 12:19 PM ---------- Previous post was at 12:17 PM ----------

Major Bug Fix

Now, with wobbly windows running, you can drag a window up to the panel, and it will not zing under the panel. The quick fix for this was to right click on the program on the taskbar and select "move to desktop X"

Glad that issue was addressed. :D

ozjd
21st April 2013, 05:10 AM
This appears to apply to 17 too. The same packages are in the 17 repos.