PDA

View Full Version : How I got my Brother HL 2270DW printer working in F18



David Batson
2nd March 2013, 07:51 PM
This is for the Brother HL-2270DW laser printer using the network connection.

I installed the official Brother Linux drivers (rpms) downloaded from Brother's website.
http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html#HL-2270DW

I installed the LPR driver following the instructions on Brother's website.
I installed the Cupswrapper driver following the instructions from Brother's website.

As root I edited the file /usr/local/Brother/Printer/HL2270DW/inf/setupPrintcap2 and changed the one instance of "printcap.local" to "printcap" and saved the file.

I restarted the CUPS service:

# systemctl restart cups.service

I opened the CUPS web interface http://localhost:631 and added the printer. I chose the last discovered Brother HL-2270DW series printer in the list. This one should have the dnssd URI.

dnssd://Brother%20HL-2270DW%20series._printer._tcp.local/

For the driver I chose the "Brother HL2270DW for CUPS (en)", which was the last one listed in the HL series. The official Brother driver does not have a hypen between the HL and 2270DW.

kjmuma
26th November 2013, 05:26 PM
Thanks man - worked for me: FC19.

Kim

mianosm
18th January 2014, 03:56 PM
I really appreciate this post. I have been from Fedora 18, to 19, to 20 - and this has worked flawlessly.

Just installing the LRP and Cups RPM from brother never works, but adding the printer through the cups administration page on your local host is flawless.

Thank you very much.