View Full Version : network hardware problem

4th March 2004, 05:54 AM
I just got my Fedora Core copy and installed it on my machine, but I am having problems with the onboard networking. Specifically (?) the Core didn't recognize it initally. So it didn't exist. After crusin' over to nVidia site (my board is an nForce) and downloading and 'installing' the .rpm that said it was a driver i could view it in my network config utility. Unfortuntly when I tried to 'activate' the device (eth0) it show 'device does not seem to be present' :confused:. Errp! I am trying the tar.gz version now, but perhaps I am missing something important? Help, and thanks.

Update: I threw an old NIC in there to see if it worked, and it worked ok, only I am still unable to access the internet from this pc because my dhcp from cable company must not be working for it. It says "obtaining ip" or something similar, runs a bit, then says "failed". sigh. Help with either of these two problems would be great.

4th March 2004, 11:02 PM
You may check with http://www.nforcershq.com/. They have some resources on setting up Fedora Core with a nForce board.


5th March 2004, 08:00 AM
I checked it out, nothing i found there seemed to work, the most frustrating part is this would be a great machine if it could only get online. In the morning I am going to try these forcedeth drivers I've seen talked about. I'll let you know how it goes.

5th March 2004, 12:28 PM
*mumbles about time zones*

6th March 2004, 04:03 AM
When you get into Gnome (or KDE) with the added in network card, have you tried system settings->network and then enable the device? This works for me most of the time, it also says the device is busy yet the internet works after that so that might help you. GL

Also, at least for me the nvidia drivers helped Nil. I didn't get network or sound support out of them so I wouldn't expect much from them if I were you.

7th March 2004, 11:51 PM
Well that is what you would think, but it sure doesn't seem to work. I either get 'device does not seem to present' (for the onbard ethernet) or 'determining ip address....{pause}failed' (thats for the old 3com I threw in to see if I was just going crazy). I'm trying differnt drivers out now, so maybe I'll figure it out.
p.s. these are the messages i get when i click activate

9th March 2004, 04:02 AM
After you get those messages though, are you able to click deactivate? As I think I got the same message (the first one) and it still worked regardless. GL

9th March 2004, 05:22 AM
really? how would you connect to the internet then... I'm trying to get dhcp up and going, what would i have to do with my browser?

9th March 2004, 08:56 AM
A second thought, though related to my first. This second NIC that I threw in seems to be detected alrite (an old 3com) and everything seems to be hunky-dory until I try to 'activate', 'service network restart' or any other way of it trying to access my cable comanies dhcp server. I'm fairly confident that this is a simple problem, as I am currently running a dual boot of Windows, which runs the card just fine (aka I can connect to the Internet). Assigning it a static ip ran the card as active, so I know the system recognizes it. My cable provider is Charter, if that makes a differance.
ps I know that this is really avoiding the main issue of my onboard ethernet, but if I could just connect to the Internet through Linux it would greatly reduce the time and hassle invovled in rebooting;)

10th March 2004, 01:19 AM
Hmm, after you try activating the eth* device then try running a
/sbin/dhclient to see what it says. This will determine if it could be a problem with how your computer is handling the dhcp information (or whether it is getting it at all). What is your network setup btw?

10th March 2004, 04:11 PM
hmmm... ok
this is the printout from my dhclient

Listening on LPF/eth0/00:60:08:9f:95:98

Sending on LPF/eth0/00:60:08:9f:95:98

Listening on LPF/lo/
Sending on LPF/lo/
Sending on Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 8
DHCPDISCOVER on lo to port 67 interval 5

DHCPDISCOVER on lo to port 67 interval 5

DHCPDISCOVER on eth0 to port 67 interval 16

DHCPDISCOVER on lo to port 67 interval 6

DHCPDISCOVER on lo to port 67 interval 6

DHCPDISCOVER on lo to port 67 interval 12

DHCPDISCOVER on eth0 to port 67 interval 18

DHCPDISCOVER on lo to port 67 interval 15

DHCPDISCOVER on eth0 to port 67 interval 12

DHCPDISCOVER on lo to port 67 interval 12

DHCPDISCOVER on eth0 to port 67 interval 7

No DHCPOFFERS received.
No working leases in persistent database - sleeping.

So it doesn't look as though my stuff is clicking. Hmpf. How and where could I set this up? Where I am the box is directly connected to the cable modem.
Is this Local Loopback my problem?

12th March 2004, 05:26 PM
Actually the reason I ask this is because when I run "ifconfig" it shows no packets Tx or Rx on eth0. Wouldn't it show a few...? And the local loopback (lo) shows about 5,000 sent and recieved. Hmmm...

29th March 2004, 04:02 AM
Two problems have ganged up to confound you. The biggest is letting charter know you will be connecting with linux. Surprise! Win..... uses proprietary code. Linux networking requires an additional script on the server side. Not a problem unless it is not there. Next problem may be the cable modem. I have had cable modem troubles too. The first OS to boot when I turned the computer on would work. Rebooting to the other OS would kill networking. I had to kill power to the cable modem as I booted the other OS. I have since connected the modem and computer with a common switch and cycle both when I change OS now. Leave the power off a couple of seconds to cycle the modem. I hope this is some help. Happy dual booting.