PDA

View Full Version : Problem setting up printer on network



leonardevens
5th February 2013, 02:50 AM
I am running Fedora 17.

My home network had a computer running Windows XP. I had set things up so I could print on an HP P2035 connected to it. But that was a long time ago. I've now replaced that computer by one running Windows 7 with the same HP P2035 printer on it.

I tried using System Settings > Printers and got a window with the old printer listed. I didn't see how to reconfigure it for the new location so I removed it with -. I then tried adding a new printer, choosing netowrk.

I get the following message

FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall.

I managed to bring up the firewall listing and I think all those services are checked. But I don't see how to turn the firewall on.

Also, I don't really know what to do next.

In a much earlier version of Fedora, I was able to get direct access to all these things from a menu, but I don't see how to do these things in the current version.

Putting in the local Ip address for the new computer doesn't help.

Can anyone direct me to a discussion of what to do?

smr54
5th February 2013, 03:30 AM
If it's an HP printer, I would try installing hplip and then running

hp-setup -i <printer_ip_address>

leonardevens
5th February 2013, 04:16 AM
I found the programs I needed under Applications>Other.

I also found why I couldn't add the printer as a windows printer using samba. It turned out the new computer was set up to sleep after 10 minutes of not being used. I changed that and I was able to add the printer.

The only problem I have now is that for some reason it requires authetication to print. When I tried printing a test page it didn't ask for authentication, but when I looked at the list of documents in the queue, I saw that it was held pending authentication. I hope that doesn't happen every time I print something. I will probably have to fiddle a bit to get it to work the way I want it to.