PDA

View Full Version : [SOLVED] Workaround to create Chrome(ium) web application desktop/menu launchers



chris215
26th January 2013, 06:55 AM
In order to have a shortcut on your desktop, you must have Gnome-Tweak-Tools, and in the desktop tab enable "Have File Manager Handle the Desktop".

In Google Chrome(ium), if you open a new tab, right click on a "web application"/link, like Gmail, and select "create shortcut", you should be able to put a launcher on the desktop or in your applications menu. This has worked for me in windows and every linux distro except for GNOME 3. If you try, nothing will show up in your applications menu, although it will create a file in "~/.local/share/applications/", and if you select deskop, you will get a launcher with a jibberish seeming title. This is because it is supposed to be creating a *.desktop file, but they made a small mistake.

The fix is this. Open the file with gedit, or your favorite text editor. The top line of any *.desktop file, or application launcher, is supposed to be "[Desktop Entry]". You will notice that insead, the top line has this: "#!/usr/bin/env xdg-open[Desktop Entry]". All you have to do is press enter between "open" and [Desktop Entry], press save, and viola! On your desktop(or in your "~/.local/share/applications" folder, that gibberish has now turned into a nice pretty launcher for Gmail, or Google Calendar, or YouTube, what have you.

If you are like me, and don't have anything on your desktop, what you really wanted was to add this to your applications menu, so that it shows up in your overview. All you have to do now is place a copy of this file in "~/.local/share/applications", and it is done. In fact, that is all you have to do to get anything to show up in the overview.

If you will notice, 'alacarte' does not work very well at this. All you have to do is create a *.desktop file, or a launcher, of your favorite thing, and put it into "~/.local/share/applications" For example, if you like using chatzilla, follow the format of the other .desktop files, and for the "exec" line, put "firefox --chat", and you will be able to launch chatzilla, independently of firefox. See
On a side note, you can make similar launchers of your favorite web applications open up in firefox as well. For the command, under "exec" in the .desktop file, type "firefox http://mail.google.com" without the quotes, and with whatever url you prefer instead of gmail. If anyone knows how to make the launcher open the firefox window without the toolbar and menu bars, that would make this even better.

Cheers! :D

hmaarrfk
26th January 2013, 07:08 PM
Make some noise:
http://code.google.com/p/chromium/issues/detail?id=170438&q=desktop%20os%3DLinux&colspec=ID%20Pri%20Mstone%20ReleaseBlock%20OS%20Ar ea%20Feature%20Status%20Owner%20Summary&start=200

chris215
26th January 2013, 07:58 PM
@hmaarrfk, thanks! I could not find that anywhere, so i wound up creating one myself... Did you create that bug report? :( I dont know how to consolidate the two or i would. Should I delete mine, and comment on the other one?

---------- Post added at 01:58 PM ---------- Previous post was at 01:56 PM ----------

Yours is more short, sweet, and to the point. This was my first ever bug report. I am guessing yours is better.

hmaarrfk
26th January 2013, 08:07 PM
Just star them both (that lest the admins know that people care about it).

---------- Post added at 10:59 AM ---------- Previous post was at 10:58 AM ----------

and write a note on yours I guess

---------- Post added at 11:07 AM ---------- Previous post was at 10:59 AM ----------

chris, did you ever figure out how to make it have its own icon?

The apps still show up as chrome, whereas I don't think of Gmail as "chrome"

chris215
26th January 2013, 08:45 PM
this issue should also be starred: http://code.google.com/p/chromium/issues/detail?id=79390

hmaarrfk
26th January 2013, 08:47 PM
Yea I got on that list.

I think that might be a Gnome-Shell problem though. each app has 2 wm-class and gnome-shell only seems to look at the 2nd one.

I tried to look for documentation on "WM_CLASS" but coulnd't find anythign that addressed both properties.

chris215
26th January 2013, 08:51 PM
if you find a way to do it, keep me posted, please? :)