PDA

View Full Version : f18 - geany saves new text files as binary



MALsPa
23rd January 2013, 03:31 AM
Using Geany in Fedora 18 (GNOME), when I create a text file and save it, the "Type" shown in Files is "Binary," and when I go back and open the file with either Geany of Gedit, I can't read the contents.

If I use Geany to edit an existing text file, then save it, there's no problem.

Can anyone point me in the right direction here? Not sure what to do.

---------- Post added at 07:31 PM ---------- Previous post was at 06:57 PM ----------

I think I've got this fixed by simply changing the settings in Geany under Document > Set Encoding to "Without encoding (None)." But I don't feel comfortable about that because that isn't how I see it set in Debian Wheezy on another computer (it's set to Unicode UTF-8, whatever that is), and my new text files don't get saved as "binary" there. So I don't really understand all this about the encoding, etc.