PDA

View Full Version : [SOLVED] Starting a gnome-terminal



Progger
20th January 2013, 02:58 PM
In most linux distro's, the keybord-combinatio Ctrl+Alt+T starts a terminal, but now, with F18 that does not work enymore, is there a solution to this? :doh:

Adunaic
20th January 2013, 03:04 PM
I don't remember Fedora having this as a keybinding. You can do ALT+F2 and type gnome-terminal or go to Settings->Keyboard->Shortcuts and add one.

Progger
20th January 2013, 03:08 PM
or go to Settings->Keyboard->Shortcuts and add one.

Did that already, it's not working that way. :doh:

Adunaic
20th January 2013, 03:29 PM
When you say it is not working, does the terminal not open? Or could you not add a shortcut?

Progger
20th January 2013, 03:39 PM
It don't open a Terminal, whatever kb-combination i add, like, for example Ctrl+Alt+T :confused:

Adunaic
20th January 2013, 03:43 PM
What did you set the command to be?

Progger
20th January 2013, 03:49 PM
Name: Terminal
Command: Ctrl+Alt+T

Even with Name: gnome-terminal did it not open a Terminal.

Rusher
20th January 2013, 03:53 PM
Okay, I see your mistake.

The name field is for the descriptive name of the key accelerator (like 'Terminal Hotkey'), the command field is for the command to run (like 'gnome-terminal'). After clicking add, you should see your new command listed as the desired name (in my case 'Terminal Hotkey') with 'Disabled' next to it. Click on 'disabled', which will change it to 'New Accelerator', and input your key combination (pressing 'Ctrl + Alt + T').

Should work.

flyingfsck
20th January 2013, 03:57 PM
Wait, are you sure gnome-terminal is installed? Do a little test first:
$ whereis gnome-terminal

What do you get?

Progger
20th January 2013, 04:04 PM
/usr/bin/gnome-terminal

It's installd, and for:

Okay, I see your mistake.

Go back to the shortcuts screen and instead of adding the command to name, add it to command. The command field is the field for the command to run after pressing the key combination. Give it a descriptive name, like Terminal and click on "Add".

After clicking it add, it should list your new command with "Disabled" next to it. Click on disabled and input your desired key combination (like Ctrl+Alt+T).

I set for the Name: Terminal
and for the command: Ctrl+Alt+T

so, the sam as suggested here.

Adunaic
20th January 2013, 04:15 PM
The name should be anything you want. The command should be "gnome-terminal" (without the quotes).

Rusher
20th January 2013, 04:36 PM
It's installd, and for:


I set for the Name: Terminal
and for the command: Ctrl+Alt+T

so, the sam as suggested here.

The name field can be anything you want, just make it descriptive.

The command field should not be the key combination, but the command you want to run. You have to set the key combination later, after you have pressed 'Add'..

After you have pressed 'Add', the dialog window closes and you get back to the shortcut manager. There should now be listed you're new shortcut, which you haven't set a combination for, yet.

Next to the listed new shortcut is the word 'Disabled', click that. It changes to 'New Accelerator...' and now, and only now, you can input your key combination.

From a cognitive perspective it's a terrible design, but once you get the grip of it, it works.

Progger
21st January 2013, 08:59 AM
Guy's, thanks to all the helpers, the last two advices did the trick, with this settings it works:

For the name field: Terminal
for the command field: gnome-terminal

and then the kb combination: Ctrl+Alt+T

and it works, the terminal opens. :D