PDA

View Full Version : Totem in F18 cannot find the video decoder



QuantumKnot
16th January 2013, 05:34 AM
Has anyone noticed that totem in the new F18 cannot find the video decoder (even though they are installed) and just plays the audio? I tried playing files encoded with xvid, h264, and RV4 and totem says it needs to find the plugins. Ultimately it cannot find one and plays with just the audio.

I've installed all the codecs from gstreamer and gst123 plays both video and audio fine. If I install the F17 version of totem, I don't see this problem and it works fine. So it definitely is a bug but just wanted to make sure I'm not the only person encountering this issue.

I've reported it on bugzilla

https://bugzilla.redhat.com/show_bug.cgi?id=895816

gadgetwiz
16th January 2013, 05:45 AM
I can confirm that the Totem plugin doesn't play this H264/MP4 in Firefox either.

http://www.quirksmode.org/html5/tests/video.html

DBelton
16th January 2013, 05:53 AM
have you installed the gstreamer1 packages. Totem in F18 uses gstreamer1 instead of the older gstreamer packages.



yum install gstreamer1* --exclude=*devel,*docs

gadgetwiz
16th January 2013, 06:07 AM
Ok, I tried those and still couldn't play H.264 files embedded in Firefox using the totem plugin. I get errors something like this..

Your browser cannot play H.264 high profile content with the HTML5 video element.

The video could not be loaded, either because the server or network failed or because the format is not supported.

http://html5test.com/

DBelton
16th January 2013, 06:11 AM
Just noticed that I can't play the h.264 in html5 here, either. I don't have totem installed, but I can play the other html5 content, just not h.264

Edit.
I have no problems playing the h.264 video if it's not html5, though. So I do have the proper codecs installed.

gadgetwiz
16th January 2013, 06:34 AM
Seems I can play flash videos encoded with h.264 but not raw h.264 videos via html5 and Fedora's default totem plug-in for Firefox.

I can play h.264 videos locally with totem (videos), vlc, xine, Whaaw and Kaffine. :)

QuantumKnot
16th January 2013, 03:07 PM
Ah, I just installed the gstreamer1 packages and now it plays. Thanks :)