PDA

View Full Version : F18 - Unable to install GCC



drooid
6th January 2013, 08:44 PM
I was going to compile 3.8 on this machine, but after attempting to install GCC, I was hit with an error.

--> Finished Dependency Resolution
Error: Package: glibc-2.16-24.fc18.i686 (fedora)
Requires: glibc-common = 2.16-24.fc18
Installed: glibc-common-2.16-28.fc18.x86_64 (@updates-testing)
glibc-common = 2.16-28.fc18
Available: glibc-common-2.16-24.fc18.x86_64 (fedora)
glibc-common = 2.16-24.fc18
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


and with --skip-broken:



Packages skipped because of dependency problems:
cloog-ppl-0.15.11-4.fc18.1.x86_64 from fedora
cpp-4.7.2-8.fc18.x86_64 from fedora
gcc-4.7.2-8.fc18.x86_64 from fedora
glibc-2.16-24.fc18.i686 from fedora
glibc-devel-2.16-24.fc18.x86_64 from fedora
glibc-headers-2.16-24.fc18.x86_64 from fedora
kernel-headers-3.6.10-4.fc18.x86_64 from fedora
libmpc-0.9-3.fc18.2.x86_64 from fedora
nss-softokn-freebl-3.14-5.fc18.i686 from fedora
ppl-0.11.2-10.fc18.x86_64 from fedora


Any tips?

DBelton
6th January 2013, 09:24 PM
enable updates-testing.

You installed glibc-common while updates-testing was still enabled, but it has been disabled with an update a week or so ago, but glibc is still in updates-testing.

just add --enablerepo=updates-testing to the yum command you used above.

nirik
7th January 2013, 03:50 AM
You could also 'yum distro-sync' to downgrade to the stable versions of the packages.