PDA

View Full Version : How do I install nouveau 32-bit?



KasumiNinja
5th January 2013, 10:03 PM
My 32-bit programs won't run. I think it's because they need a 32 bit nouveau driver. I only see a 64-bit driver available. Anyone knows how I can install a 32-bit nouveau-driver?


libGL error: failed to load driver: nouveau
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.



yum search nouveau
Loaded plugins: langpacks, presto, refresh-packagekit, remove-with-leaves
============================= N/S Matched: nouveau =============================
xorg-x11-drv-nouveau.x86_64 : Xorg X11 nouveau video driver for NVIDIA graphics
: chipsets

PatMcLJr
7th January 2013, 04:00 PM
I'll guess at you need the whole 32 bit OS for that to work.

What programs are you trying to use? Maybe some else would know how to help?

DBelton
7th January 2013, 04:11 PM
with the nouveau driver, I haven't ever seen any instance where you need the 32 bit version installed when running a 64 bit OS.

Now some of the other 32 bit libs need to be installed (varies depending upon what 32 bit apps you are trying to run), but not the nouveau driver itself.

PabloTwo
7th January 2013, 04:23 PM
Have you tried:

yum install mesa-libGL.i686